描述

The nth Triangular number, T(n) = 1 + … + n, is the sum of the first n integers. It is the number of points in a triangular array with n points on side. For example T(4):

X X X X X X X X X X

Write a program to compute the weighted sum of triangular numbers:

W(n) = SUM[k = 1…nk * T(k + 1)]

 
输入
The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.
Each dataset consists of a single line of input containing a single integer n, (1 ≤ n ≤300), which is the number of points on a side of the triangle.
输出
For each dataset, output on a single line the dataset number (1 through N), a blank, the value of n for the dataset, a blank, and the weighted sum ,W(n), of triangular numbers for n.
样例输入
4
3
4
5
10
样例输出
1 3 45
2 4 105
3 5 210
4 10 2145

int T(int x)
{
    int z=0,i;
    for(i=1;i<=x;i++)
            z=z+i;
    return z;
}
#include<stdio.h>
int main()
{
    int n,a;
    scanf("%d",&n);
    for(a=1;a<=n;a++)
    {
              int T(int x);
              int t,k,w=0;
              scanf("%d",&t);
              for(k=1;k<=t;k++)
              {
                   w=w+k*T(k+1);
              }        
              printf("%d %d %d\n",a,t,w);
    }
              return 0;           
}