B - Problem B (最小公倍数) :HDU - 1019

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105. 

InputInput will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer. 
OutputFor each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer. 
Sample Input

2
3 5 7 15
6 4 10296 936 1287 792 1

Sample Output

105
10296

题目意思:求所给数的最小公倍数;
解题思路:两个两个的求,主要不要超范围了;


#include <iostream>
#include <stdio.h>
using namespace std;

typedef long long ll;

ll pand(ll t,ll n1)
{
    while(1)
    {
        ll temp = t % n1;
        if(temp == 0)
            return n1;
        t = n1;
        n1 = temp;
    }
}

int main()
{
   int N;
   cin>>N;
   while(N--)
   {
       ll t,n1;
       ll n;
       cin>>n;
       cin>>t;
       n--;
       while(n--)
       {
           cin>>n1;
           if(t==0||n1==0)
           {
               t=0;
               break;
           }

           if(t < n1)
           {
               ll temp = t;
               t = n1;
               n1 = temp;
           }
           ll sum = t*n1;
           ll x = pand(t,n1);
            t = sum/x;
       }
       cout<<t<<endl;
   }

    return 0;
}

 

posted @ 2017-08-05 09:19  山杉三  阅读(152)  评论(0编辑  收藏  举报