HDU 1013 Digital Roots(九余数定理)

Digital Roots

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 80782    Accepted Submission(s): 25278


Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
 

 

Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
 

 

Output
For each integer in the input, output its digital root on a separate line of the output.
 

 

Sample Input
24 39 0
 

 

Sample Output
6 3
 

 

Source
 

 

Recommend
We have carefully selected several similar problems for you:  1017 1021 1012 1048 1016 
 
分析:最后得到的结果有九种可能性 1-9,当数n<10时,n%9余数为0的时候对应9,其余的余数和最终结果相同
  如果n>=10 那么 数根也会和呈现出1-9的循环,把余数0看作9的话,则余数呈现对应的1-9循环  那么求出余数即可
代码如下:
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
char a[20100];
int main()
{
    int n,sum;
    while(scanf("%s",a)!=EOF)
    {
        if(strlen(a)==1&&a[0]=='0')break;
       sum=0;
       for(int i=0;i<strlen(a);i++)
        sum+=a[i]-'0';
        sum=sum%9;
       if(sum==0)puts("9");
       else printf("%d\n",sum);
    }
    return 0;
}

 

 
 
 
 
 
posted @ 2017-09-09 11:15  hinata_hajime  阅读(155)  评论(0编辑  收藏  举报