Power Strings POJ - 2406 (KMP)

                                                                                                               

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.
Sample Output
1
4
3
Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.
 
分析: 题目求字符串的最小循环节,可以利用KMP的next数组性质
next[len]表示字符串前缀和后缀的最大公共长度。
比如长度为8的字符串 abababab   next[len]=6 即最长公共长度为6
进而推出最小循环节即为2
代码如下
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;

const int N = 1000002;
int next[N];
char S[N], T[N];
int slen, tlen;

void getNext()
{
    int j, k;
    j = 0; k = -1; next[0] = -1;
    while(j < tlen)
        if(k == -1 || T[j] == T[k])
            next[++j] = ++k;
        else
            k = next[k];

}
int main()
{

    int TT;
    int i, cc,ans;
    while(scanf("%s",T)!=EOF)
    {
        if(T[0]=='.')
            break;
       tlen=strlen(T);
        getNext();
        ans=tlen-next[tlen];
        if(tlen%ans==0)
        printf("%d\n",tlen/ans);
        else
        printf("1\n");
    }
    return 0;
}

 

 
 
posted @ 2017-08-16 17:05  hinata_hajime  阅读(113)  评论(0编辑  收藏  举报