POJ 3468 A Simple Problem with Integers(线段树/区间更新)

题目链接: 传送门

A Simple Problem with Integers

Time Limit: 5000MS     Memory Limit: 131072K

Description

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of Aa, Aa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

HINT

The sums may exceed the range of 32-bit integers.

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define lson l ,m , rt << 1
#define rson m + 1 , r ,rt << 1 | 1 
typedef __int64 LL;
const int maxn = 100005;
LL sum[maxn<<2],lazy[maxn<<2];

void PushUp(int rt)
{
	sum[rt] = sum[rt<<1] + sum[rt<<1|1];
}

void PushDown(int rt,int m)
{
	if (lazy[rt])
	{
		lazy[rt<<1] += lazy[rt];
		lazy[rt<<1|1] += lazy[rt];
		sum[rt<<1] += (m - (m>>1)) * lazy[rt];
		sum[rt<<1|1] += (m>>1) * lazy[rt];
		lazy[rt] = 0;
	}
}

void build(int l,int r,int rt)
{
	if (l == r)
	{
		scanf("%I64d",&sum[rt]);
		lazy[rt] = 0;
		return;
	}
	int m = (l + r) >> 1;
	build(lson);
	build(rson);
	PushUp(rt);
} 

void upd(int L,int R,int c,int l,int r,int rt)
{
	if (L <= l && r <= R)
	{
		sum[rt] += (LL)(r - l + 1) * c;
		lazy[rt] += c;
		return;
	}
	PushDown(rt,r - l + 1);
	int m = (l + r) >> 1;
	if (L <= m)	upd(L,R,c,lson);
	if (R > m)	upd(L,R,c,rson);
	PushUp(rt);
}

LL qry(int L,int R,int l,int r,int rt)
{
	if (L <= l && r <= R)
	{
		return sum[rt];
	}
	PushDown(rt,r - l + 1);
	int m = (l + r) >> 1;
	LL ret = 0;
	if (L <= m)	ret += qry(L,R,lson);
	if (R > m)	ret += qry(L,R,rson);
	return ret;
}

int main()
{
	int N,Q,a,b,c;
	char opt;
	while (~scanf("%d%d",&N,&Q))
	{
		build(1,N,1);
		while (Q--)
		{
			getchar();
			scanf("%c",&opt);
			if (opt == 'C')
			{
				scanf("%d%d%d",&a,&b,&c);
				upd(a,b,c,1,N,1);
			}
			else
			{
				scanf("%d%d",&a,&b);
				printf("%I64d\n",qry(a,b,1,N,1));
			}
		}
	}
	return 0;
}
posted @   zxzhang  阅读(189)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
· 上周热点回顾(3.3-3.9)
点击右上角即可分享
微信分享提示

目录导航