Codeforces Round #268 (Div. 1)A. 24 Game

题目链接: 传送门

24 Game

time limit per test:1 second     memory limit per test:256 megabytes

Description

Little X used to play a card game called "24 Game", but recently he has found it too easy. So he invented a new game.
Initially you have a sequence of n integers: 1, 2, ..., n. In a single step, you can pick two of them, let's denote them a and b, erase them from the sequence, and append to the sequence either a + b, or a - b, or a × b.
After n - 1 steps there is only one number left. Can you make this number equal to 24?

Input

The first line contains a single integer n (1 ≤ n ≤ 10^5).

Output

If it's possible, print "YES" in the first line. Otherwise, print "NO" (without the quotes).
If there is a way to obtain 24 as the result number, in the following n - 1 lines print the required operations an operation per line. Each operation should be in form: "a op b = c". Where a and b are the numbers you've picked at this operation; op is either "+", or "-", or "*"; c is the result of corresponding operation. Note, that the absolute value of c mustn't be greater than 1018. The result of the last operation must be equal to 24. Separate operator sign and equality sign from numbers with spaces.
If there are multiple valid answers, you may print any of them.

Sample Input

1

8

Sample Output

NO

YES
8 * 7 = 56
6 * 5 = 30
3 - 4 = -1
1 - 2 = -1
30 - -1 = 31
56 - 31 = 25
25 + -1 = 24

解题思路:

题目大意:给一个数n,问能不能由1~n通过加减乘除组成24
解题思路:If n ≤ 3, it's easy to find that it's impossible to make 24, because the maximal number they can form is 9.
If n > 5, we can simply add n - (n - 1) = 1, 24 * 1 = 24 at the end of the solution to the number n - 2.
So we can find the solution of 4, 5 by hand. 1 * 2 * 3 * 4 = 24, (5 - 3) * 4 * (2 + 1) = 24
另外,在n > 5时,可以通过1+5 = 6,6-6=0,0x = 0,再由23*4=24.

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

int main()
{
	int N;
	while (~scanf("%d",&N))
	{
		if (N < 4)
		{
			printf("NO\n");
			continue;
		}
		if (N == 4)
		{
			printf("YES\n");
			printf("1 * 2 = 2\n");
			printf("2 * 3 = 6\n");
			printf("4 * 6 = 24\n");
		} 
		else if (N == 5)
		{
			printf("YES\n");
			printf("5 - 3 = 2\n");
			printf("2 + 1 = 3\n");
			printf("2 * 3 = 6\n");
			printf("6 * 4 = 24\n");
		}
		else if (N > 5)
		{
			printf("YES\n");
			printf("5 + 1 = 6\n");
			printf("6 - 6 = 0\n");
			for (int i = 7;i <= N;i++)
			{
				printf("0 * %d = 0\n",i);
			}
			printf("2 + 0 = 2\n");
			printf("2 * 3 = 6\n");
			printf("6 * 4 = 24\n");
		}
	}
	return 0;
}
posted @   zxzhang  阅读(165)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
· 上周热点回顾(3.3-3.9)
点击右上角即可分享
微信分享提示

目录导航