POJ 1258 Agri-Net(最小生成树 Prim+Kruskal)
题目链接: 传送门
Agri-Net
Description
Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.
The distance between any two farms will not exceed 100,000.
Input
The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.
Output
For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.
Sample Input
4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0
Sample Output
28
Prim算法O(V^2)
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int INF = 0x3f3f3f3f;
const int MAX_V = 105;
int edge[MAX_V][MAX_V];
int dis[MAX_V];
bool vis[MAX_V];
int N;
int prim()
{
memset(dis,INF,sizeof(dis));
memset(vis,false,sizeof(vis));
for (int i = 1;i <= N;i++)
{
dis[i] = edge[i][1];
}
dis[1] = 0;
vis[1] = true;
int sum = 0;
for (int i = 1;i < N;i++)
{
int tmp = INF,pos;
for (int j = 1;j <= N;j++)
{
if(!vis[j] && tmp > dis[j])
{
tmp = dis[j];
pos = j;
}
}
if (tmp == INF) return 0;
vis[pos] = true;
sum += dis[pos];
for(int j = 1;j <= N;j++)
{
if (!vis[j] && edge[pos][j] < dis[j])
{
dis[j] = edge[pos][j];
}
}
}
return sum;
}
int main()
{
while (~scanf("%d",&N))
{
for (int i = 1;i <= N;i++)
{
for (int j = 1;j <= N;j++)
{
scanf("%d",&edge[i][j]);
}
}
int res = prim();
printf("%d\n",res);
}
return 0;
}
Prim算法O(ElogV)
#include<iostream>
#include<vector>
#include<queue>
#include<utility>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef __int64 LL;
typedef pair<int,int>pii; //first 最短距离 second 顶点编号
const int INF = 0x3f3f3f3f;
const int MAX = 105;
struct edge{
int to,cost;
edge(int t,int c):to(t),cost(c){}
};
vector<edge>G[MAX];
int N,dis[MAX];
bool vis[MAX];
int prim()
{
int res = 0;
priority_queue<pii,vector<pii>,greater<pii> >que;
memset(dis,INF,sizeof(dis));
memset(vis,false,sizeof(vis));
dis[1] = 0;
que.push(pii(0,1));
while (!que.empty())
{
pii p = que.top();
que.pop();
int v = p.second;
if (vis[v] || p.first > dis[v]) continue;
vis[v] = true;
res += dis[v];
for (int i = 0;i < G[v].size();i++)
{
edge e = G[v][i];
if (dis[e.to] > e.cost)
{
dis[e.to] = e.cost;
que.push(pii(dis[e.to],e.to));
}
}
}
return res;
}
int main()
{
while (~scanf("%d",&N))
{
int tmp;
for (int i = 1;i <= N;i++)
{
G[i].clear();
for (int j = 1;j <= N;j++)
{
scanf("%d",&tmp);
G[i].push_back(edge(j,tmp));
}
}
int res = prim();
printf("%d\n",res);
}
return 0;
}
Kruskal算法O(ElogV)
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int INF = 0x3f3f3f3f;
const int MAX = (105*105-105)/2;
struct Edge{
int u,v,w;
};
int N,father[MAX],rk[MAX];
struct Edge edge[MAX];
bool cmp(Edge x,Edge y)
{
return x.w < y.w;
}
void init()
{
memset(father,0,sizeof(father));
memset(rk,0,sizeof(rk));
for (int i = 0;i <= N;i++)
{
father[i] = i;
}
}
int find(int x)
{
int r = x;
while (father[r] != r)
{
r = father[r];
}
int i = x,j;
while (i != r)
{
j = father[i];
father[i] = r;
i = j;
}
return r;
}
/*int find(int x)
{
return x == father[x]?x:father[x] = find(father[x]);
}*/
void unite(int x,int y)
{
int fx,fy;
fx = find(x);
fy = find(y);
if (fx == fy) return;
if (rk[fx] < rk[fy])
{
father[fx] = fy;
}
else
{
father[fy] = fx;
if (rk[x] == rk[y])
{
rk[x]++;
}
}
}
/*void unite(int x,int y)
{
int fx = find(x),fy = find(y);
if (fx != fy)
{
father[fx] = fy;
}
}*/
int main()
{
while (~scanf("%d",&N))
{
int tmp,cnt = 0,sum = 0;
for (int i = 1;i <= N;i++)
{
for (int j = 1;j <= N;j++)
{
scanf("%d",&tmp);
if (i < j)
{
edge[cnt].u = i;
edge[cnt].v = j;
edge[cnt].w = tmp;
cnt++;
}
}
}
init();
sort(edge,edge+cnt,cmp);
for (int i = 0;i < cnt;i++)
{
int x,y;
x = find(edge[i].u);
y = find(edge[i].v);
if (x != y)
{
unite(x,y);
sum += edge[i].w;
}
}
printf("%d\n",sum);
}
return 0;
}
┆ 凉 ┆ 暖 ┆ 降 ┆ 等 ┆ 幸 ┆ 我 ┆ 我 ┆ 里 ┆ 将 ┆ ┆ 可 ┆ 有 ┆ 谦 ┆ 戮 ┆ 那 ┆ ┆ 大 ┆ ┆ 始 ┆ 然 ┆
┆ 薄 ┆ 一 ┆ 临 ┆ 你 ┆ 的 ┆ 还 ┆ 没 ┆ ┆ 来 ┆ ┆ 是 ┆ 来 ┆ 逊 ┆ 没 ┆ 些 ┆ ┆ 雁 ┆ ┆ 终 ┆ 而 ┆
┆ ┆ 暖 ┆ ┆ 如 ┆ 地 ┆ 站 ┆ 有 ┆ ┆ 也 ┆ ┆ 我 ┆ ┆ 的 ┆ 有 ┆ 精 ┆ ┆ 也 ┆ ┆ 没 ┆ 你 ┆
┆ ┆ 这 ┆ ┆ 试 ┆ 方 ┆ 在 ┆ 逃 ┆ ┆ 会 ┆ ┆ 在 ┆ ┆ 清 ┆ 来 ┆ 准 ┆ ┆ 没 ┆ ┆ 有 ┆ 没 ┆
┆ ┆ 生 ┆ ┆ 探 ┆ ┆ 最 ┆ 避 ┆ ┆ 在 ┆ ┆ 这 ┆ ┆ 晨 ┆ ┆ 的 ┆ ┆ 有 ┆ ┆ 来 ┆ 有 ┆
┆ ┆ 之 ┆ ┆ 般 ┆ ┆ 不 ┆ ┆ ┆ 这 ┆ ┆ 里 ┆ ┆ 没 ┆ ┆ 杀 ┆ ┆ 来 ┆ ┆ ┆ 来 ┆
【推荐】国内首个AI IDE,深度理解中文开发场景,立即下载体验Trae
【推荐】编程新体验,更懂你的AI,立即体验豆包MarsCode编程助手
【推荐】抖音旗下AI助手豆包,你的智能百科全书,全免费不限次数
【推荐】轻量又高性能的 SSH 工具 IShell:AI 加持,快人一步
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
· 上周热点回顾(3.3-3.9)