HDU 1002 A + B Problem II

A + B Problem II

  Time Limit: 1000MS      Memory Limit: 65536K

Total Submissions: 16104    Accepted: 4547

Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2
1 2
112233445566778899 998877665544332211

Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

思路:

把数值每一位拆开存进数组,利用ASCII码转换数据,然后进行相加。

#include<stdio.h>
#include<string.h>
int main()
{
    char a[1003];
    char b[1003];
    char ans[1003];
    int T;
    scanf("%d",&T);
    int cas = 0 ;
    while(T--)
    {
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        memset(ans,0,sizeof(ans));
        scanf("%s",a);
        scanf("%s",b);
        strrev(a);
        strrev(b);
        int i;
        for(i = 0 ; a[i]&&b[i];i++)
        {
            ans[i]+=a[i]+b[i]-48;
            if(ans[i]>'9'){
            ans[i+1]++;
            ans[i]-=10;
            }
        }
        while(a[i]){
            ans[i]+=a[i];
            if(ans[i]>'9'){
            ans[i+1]++;
            ans[i]-=10;
            }
            i++;
        }
        while(b[i]){
            ans[i]+=b[i];
            if(ans[i]>'9'){
            ans[i+1]++;
            ans[i]-=10;
            }
            i++;
        }
        if(ans[i]==1)ans[i]+=48;
        strrev(ans);
        strrev(a);
        strrev(b);
        if(cas)printf("\n");
        printf("Case %d:\n",++cas);
        printf("%s + %s = %s\n",a,b,ans);
    }
}
posted @   zxzhang  阅读(151)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
· 上周热点回顾(3.3-3.9)
点击右上角即可分享
微信分享提示

目录导航