POJ 3617 Best Cow Line (贪心)

Best Cow Line

  Time Limit: 1000MS      Memory Limit: 65536K

Total Submissions: 16104    Accepted: 4547

Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.
FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.
FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.
Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

  • Line 1: A single integer: N
  • Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

Sample Input

6
A
C
D
B
C
B

Sample Output

ABCBCD

思路:

  • 按照字典序比较S和S的反转字符串S'
  • 如果S较小,就从S的开头取出一个文字,追加到T的末尾
  • 如果S'较小,就从S的末尾取出一个文字,追加到T的末尾
#include<stdio.h>

int main()
{
	int N,i,count = 0;
	char ans[2005];
	
	scanf("%d",&N);
	
	for (i = 0;i < N;i++)
	{
		getchar();
		scanf("%c",&ans[i]);
	}
	
	int bgn = 0,last = N - 1;
	
	while (bgn <= last)
	{
		bool left = false;
		
		for (i = 0;bgn+i < last + 1;i++)
		{
			if (ans[bgn + i] < ans[last - i])
			{
				left = true;
				break;
			}
			else if(ans[bgn + i] > ans[last - i])
			{
				left = false;
				break;
			}
		}
		
		if (left)
		{
			putchar(ans[bgn++]);
			count++;
		}
		else
		{
			putchar(ans[last--]);
			count++;
		}
		
		if(count % 80 == 0)
		{
			printf("\n");
		}
	}
	return 0;
} 
posted @   zxzhang  阅读(244)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
· 上周热点回顾(3.3-3.9)
点击右上角即可分享
微信分享提示

目录导航