POJ 2456 二分

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). 

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C 

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS: 

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3. 

Huge input data,scanf is recommended.

题目大意:

   有n间牛舍,c头牛,牛舍排成一条直线,要求把每头牛都放在离其它牛尽可能远的牛舍,其实也就是要最大化最近的两头牛的距离,然后输出距离。用二分搜索可以解决,再加点贪心。

代码如下:

  

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
const int INF=1000000000;
const int maxn=100005;
int n,c;
int x[maxn];
bool C(int d)//判断是否满足条件,C(d)=可以安排所有牛的位置使得任意的牛的间距都不小于d
{
    int last=0;
    for(int i=1; i<c; i++)
    {
        int next=last+1;
        while(next<n&&x[next]-x[last]<d)
        {
            next++;
        }
        if(next==n) return false;
        last=next;
    }
    return true;
}
int main()
{
    while(scanf("%d%d",&n,&c)!=EOF)
    {
        for(int i=0; i<n; i++)
        {
            scanf("%d",&x[i]);
        }
        sort(x,x+n);//对牛舍位置排序
        int lb=0,ub=INF;
        while(ub-lb>1)
        {
            int mid=(lb+ub)/2;
            if(C(mid)) lb=mid;
            else ub=mid;
        }
        printf("%d\n",lb);
    }
    return 0;
}

  

posted @ 2015-08-16 00:40  Zeroinger  阅读(107)  评论(0编辑  收藏  举报
无觅关联推荐,快速提升流量