PAT 甲级1002 A+B for Polynomials (25)

1002. A+B for Polynomials (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

 

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2

题意:合并多项式
思路:简单的水题,不过注意细节,譬如合并之后某一项的系数为0,那么这一项不作考虑,需要去除。
若合并之后多项式值为0,直接输出0就行了(题目貌似也没特别说明这个情况该输出什么,坑)。
AC代码:
#define _CRT_SECURE_NO_DEPRECATE
#include<iostream>
#include<algorithm>
#include<set>
#include<queue>
#include<cmath>
#include<vector>
#include<bitset>
#include<string>
using namespace std;
const int N_MAX = 10+5;
struct poly {
  int exp;
  double coe;
  bool operator <(const poly&b) const{
    return exp < b.exp;
  }
};
poly P1[N_MAX],P2[N_MAX],P[N_MAX];
int k1, k2;
int main() {
  scanf("%d",&k1);
  for (int i = 0; i < k1;i++) {
    scanf("%d%lf",&P1[i].exp,&P1[i].coe);
  }
  scanf("%d",&k2);
  for (int i = 0; i < k2;i++) {
    scanf("%d%lf",&P2[i].exp,&P2[i].coe);
  }
  
  sort(P1, P1 + k1);
  sort(P2, P2 + k2);

  int t1 = 0, t2 = 0,t=0;
  while (t1<k1&&t2<k2) {
    double tmp=1;//不为0即可
    if (P1[t1].exp == P2[t2].exp) {
       tmp= P1[t1].coe + P2[t2].coe;
      if (tmp) {//系数不为0,则要算进去
        P[t].exp = P1[t1].exp;
        P[t].coe = P1[t1].coe + P2[t2].coe;
      }
      t1++;
      t2++;
    }
    else if (P1[t1].exp<P2[t2].exp) {//那个指数小用哪个
      P[t].exp = P1[t1].exp;
      P[t].coe = P1[t1].coe;
      t1++;
    }
    else if (P1[t1].exp>P2[t2].exp) {//那个指数小用哪个
      P[t].exp = P2[t2].exp;
      P[t].coe = P2[t2].coe;
      t2++;
    }
    if(tmp)t++;
  }

  while (t1 < k1) {
    P[t].exp = P1[t1].exp;
    P[t].coe = P1[t1].coe;
    t1++;
    t++;
  }
  while (t2 < k2) {
    P[t].exp = P2[t2].exp;
    P[t].coe = P2[t2].coe;
    t2++;
    t++;
  }

  if (t) {
    printf("%d ", t);
    for (int i = 0; i < t; i++) {
      printf("%d %.1f%c", P[t - i - 1].exp, P[t - i - 1].coe, i + 1 == t ? '\n' : ' ');
    }
  }
  else printf("%d\n",t);

}

 

 

posted on 2017-09-26 00:10  ZefengYao  阅读(154)  评论(0编辑  收藏  举报

导航