hdu 3874 Assign the task

                                                                        Assign the task

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2600    Accepted Submission(s): 1098


Problem Description
There is a company that has N employees(numbered from 1 to N),every employee in the company has a immediate boss (except for the leader of whole company).If you are the immediate boss of someone,that person is your subordinate, and all his subordinates are your subordinates as well. If you are nobody's boss, then you have no subordinates,the employee who has no immediate boss is the leader of whole company.So it means the N employees form a tree.

The company usually assigns some tasks to some employees to finish.When a task is assigned to someone,He/She will assigned it to all his/her subordinates.In other words,the person and all his/her subordinates received a task in the same time. Furthermore,whenever a employee received a task,he/she will stop the current task(if he/she has) and start the new one.

Write a program that will help in figuring out some employee’s current task after the company assign some tasks to some employee.
 

 

Input
The first line contains a single positive integer T( T <= 10 ), indicates the number of test cases.

For each test case:

The first line contains an integer N (N ≤ 50,000) , which is the number of the employees.

The following N - 1 lines each contain two integers u and v, which means the employee v is the immediate boss of employee u(1<=u,v<=N).

The next line contains an integer M (M ≤ 50,000).

The following M lines each contain a message which is either

"C x" which means an inquiry for the current task of employee x

or

"T x y"which means the company assign task y to employee x.

(1<=x<=N,0<=y<=10^9)
 

 

Output
For each test case, print the test case number (beginning with 1) in the first line and then for every inquiry, output the correspond answer per line.
 

 

Sample Input
1 5 4 3 3 2 1 3 5 2 5 C 3 T 2 1 C 3 T 3 2 C 3
 

 

Sample Output
Case #1:
-1
1
2
题意:一棵树,父亲节点是其子节点boss,现在要分配工作,分配给树的某个节点,若分配给该节点,该节点的所有儿子节点都会分配到这个任务,若之前这些节点有其他的任务,那么放下以前的任务,马上开始做当前分配下来的任务。
现在给出两种操作,一种就是分配任务给某个节点,还有一种操作是查询某个节点当前在做的任务并输出之。
思路:每次的修改操作可以是层序遍历进行树的局部修改即可。
AC代码:
#define _CRT_SECURE_NO_DEPRECATE
#include<iostream>
#include<algorithm>
#include<string>
#include<set>
#include<map>
#include<vector>
#include<queue>
using namespace std;
const int N_MAX = 50000+4;
vector<int>G[N_MAX];
queue<int>que;
int cur_work[N_MAX];
int print[N_MAX];
int N,M;

void ceng_xu(int emp,int y) {
    que.push(emp);
    while (!que.empty()) {
        int emp = que.front();
        que.pop();
        cur_work[emp] = y;
        for (int i = 0; i < G[emp].size(); i++) {
            que.push(G[emp][i]);
        }
    }
}

int main() {
    int t,k=0;
    scanf("%d",&t);
    while (t--) {
        int num = 0;//用于记录print赋值的次数
        k++;//测试样本数
        memset(cur_work,-1,sizeof(cur_work));
        scanf("%d",&N);
        for (int i = 0; i < N - 1; i++) {
            int emp, boss;//下标都从1开始
            scanf("%d%d",&emp,&boss);
            G[boss].push_back(emp);
        }
        scanf("%d",&M);
        for (int i = 0; i < M; i++) {
            char c;
            scanf(" %c",&c);
            if (c == 'C') {
                int a;
                scanf("%d",&a);
                print[num++]=cur_work[a];
            }
            else {
                int emp, y;
                scanf("%d%d",&emp,&y);
                ceng_xu(emp, y);
            }
        }
        for (int i = 0; i < N; i++) {
            G[i].clear();
        }

        printf("Case #%d:\n",k);
        for (int i = 0; i < num; i++)
            printf("%d\n",print[i]);
    }
    return 0;
}

 

posted on 2017-04-05 16:05  ZefengYao  阅读(246)  评论(0编辑  收藏  举报

导航