AFO

3942: [Usaco2015 Feb]Censoring

3942: [Usaco2015 Feb]Censoring

Time Limit: 10 Sec Memory Limit: 128 MB
Submit: 964 Solved: 480
[Submit][Status][Discuss]

Description

Farmer John has purchased a subscription to Good Hooveskeeping magazine for his cows, so they have plenty of material to read while waiting around in the barn during milking sessions. Unfortunately, the latest issue contains a rather inappropriate article on how to cook the perfect steak, which FJ would rather his cows not see (clearly, the magazine is in need of better editorial oversight).

FJ has taken all of the text from the magazine to create the string S of length at most 10^6 characters. From this, he would like to remove occurrences of a substring T to censor the inappropriate content. To do this, Farmer John finds the first occurrence of T in S and deletes it. He then repeats the process again, deleting the first occurrence of T again, continuing until there are no more occurrences of T in S. Note that the deletion of one occurrence might create a new occurrence of T that didn't exist before.

Please help FJ determine the final contents of S after censoring is complete

有一个S串和一个T串,长度均小于1,000,000,设当前串为U串,然后从前往后枚举S串一个字符一个字符往U串里添加,若U串后缀为T,则去掉这个后缀继续流程。

Input

The first line will contain S. The second line will contain T. The length of T will be at most that of S, and all characters of S and T will be lower-case alphabet characters (in the range a..z).

Output

The string S after all deletions are complete. It is guaranteed that S will not become empty during the deletion process.

Sample Input

whatthemomooofun
moo

Sample Output

whatthefun

HINT

Source

Silver


KMP
建一个栈表示未被匹配的字符
每次只要看一看新加入的字符是否能接栈顶继续匹配,不行的话不断查找nex数组知道可以为止,
每次匹配长度达到c串长度时栈的深度-c串长度


#include<iostream>
#include<cstdio>
#define M 4000000
using namespace std;

int la[M],i,m,n,j,k,a[M][2],nex[M],b[M],top,t;
char d[M],c[M];

int main()
{
	scanf("%s%s",d+1,c+1);

	for(n=1;1;n++) if(d[n]<'a' || d[n]>'z') break; 
	for(m=1;1;m++) if(c[m]<'a' || c[m]>'z') break; 
	n-=1; c[m]='&'; m-=1;  kmp(c);
	
	for(int i=2,j=0; i<=m;i++)
	{
		while(j && (c[i]!=c[j+1])) j=nex[j];
		if(c[j+1]==c[i]) j+=1;
		nex[i]=j;
	}

	for(i=1;i<=n;i++)
	{
		t=a[top][0];
		if(c[a[top][0]+1]==d[i]) t=a[top][0];
		else while(t && d[i]!=c[t+1]) t=nex[t];
		if(c[t+1]!=d[i]) t=-1; 
		top+=1;
		a[top][0]=t+1;	a[top][1]=i;	
		if(a[top][0]==m) top-=m;
	}
	for(i=1;i<=top;i++) printf("%c",d[a[i][1]]);
}
posted @ 2018-10-22 14:43  ZUTTER☮  阅读(183)  评论(0编辑  收藏  举报