HDU1232 畅通工程 (并查集模板题)

畅通工程

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 38471    Accepted Submission(s): 20404


Problem Description
某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路?
 

 

Input
测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。
注意:两个城市之间可以有多条道路相通,也就是说
3 3
1 2
1 2
2 1
这种输入也是合法的
当N为0时,输入结束,该用例不被处理。
 

 

Output
对每个测试用例,在1行里输出最少还需要建设的道路数目。
 

 

Sample Input
4 2 1 3 4 3 3 3 1 2 1 3 2 3 5 2 1 2 3 5 999 0 0
 

 

Sample Output
1 0 2 998
Hint
Hint
Huge input, scanf is recommended.
感概:现在看以前的代码我都不忍直视了,太烂了。
#include <cstdio>
#include <iostream>
#include <cstdlib>
#include <algorithm>
#include <ctime>
#include <cmath>
#include <string>
#include <cstring>
#include <stack>
#include <queue>
#include <list>
#include <vector>
#include <map>
#include <set>
using namespace std;

const int INF=0x3f3f3f3f;
const double eps=1e-10;
const double PI=acos(-1.0);
#define maxn 2000
int n, m, cnt;
int root[maxn];
void init_root()
{
    for(int i = 1; i <= n; i++)
        root[i] = i;
}
int find_root(int x)
{
    if(x == root[x])
        return x;
    else
        return root[x] = find_root(root[x]);
}
void uni(int a, int b)
{
    int x = find_root(a);
    int y = find_root(b);
    if(x != y)
    {
        root[y] = x;
        cnt++;
    }
}
int main()
{
    while(~scanf("%d", &n))
    {
        if(n == 0)
            break;
        init_root();
        scanf("%d", &m);
        int a, b;
        cnt = 0;
        for(int i = 0; i < m; i++)
        {
            scanf("%d%d", &a, &b);
            if(cnt == n-1)
                continue;
            uni(a, b);
        }
        int ans = 0;
        for(int i = 1; i <= n; i++)
            if(root[i] == i)
                ans++;
        printf("%d\n", ans-1);
    }
    return 0;
}

 

posted @ 2015-01-23 11:16  JoneZP  阅读(184)  评论(0编辑  收藏  举报