1054 The Dominant Color (20)

Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800x600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (<=800) and N (<=600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0, 224). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:

5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24

Sample Output:

24

#include<stdio.h>
#include<map>
using namespace std;
int main() {
	map<int, int> mp;
	int m, n, t, num = 0, color;
	scanf("%d %d", &m, &n);
	for (int i = 0; i < n; i++) {
		for (int j = 0; j < m; j++) {
			scanf("%d", &t);
			mp[t]++;
		}
	}
	for (map<int, int>::iterator it = mp.begin(); it != mp.end(); it++) {
		//printf("%d %d\n", it->first, it->second);
		if (it->second > num) {
			num = it->second;
			color = it->first;
		}
	}                 
	printf("%d\n", color);
	return 0;
}
posted @ 2018-07-16 22:53  Cirno-9  阅读(61)  评论(0编辑  收藏  举报