1024 Palindromic Number (25)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (<= 10^10^) is the initial numer and K (<= 100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:

67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353
3
其他一些易错测试点:

   7359915502 100

   484 4

#include<stdio.h>
#include<string.h>
struct bign {
    int d[1000], len;
    bign() {
        memset(d, 0, sizeof(d));
        len = 0;
    }
 };

bign change(char str[]) {
    bign a;
    a.len = strlen(str);
    for (int i = 0; i < a.len; i++) {  //注意如果输出的时候非回文数,要注意输出的顺序
        a.d[i] = str[a.len - i - 1] - '0';
    }
    return a;
}

bool Judge(bign a) {
    for (int i = 0; i <= a.len / 2; i++) {
        if (a.d[i] != a.d[a.len - 1 - i]) return false;
    }
    return true;
}

bign reverse_add(bign a) {
    bign b;
    int carry = 0;
    for (int i = 0; i < a.len; i++) {
        int temp = a.d[i] + a.d[a.len - 1 - i] + carry;
        b.d[b.len++] = temp % 10;
        carry = temp / 10;
    }
    if (carry != 0) b.d[b.len++] = carry;
    return b;
}

int main() {
    char str[1000];
    int n, i;
    scanf("%s%d", str, &n);
    bign s = change(str);
    for (i = 0; i < n; i++) {
        if (Judge(s) == true) break;
        else {
            s = reverse_add(s);
        }
    }
    for (int i = s.len - 1; i >= 0; i--) {
        printf("%d", s.d[i]);
    }
    printf("\n%d\n", i);
    return 0;
}

 




posted @ 2018-06-17 22:02  Cirno-9  阅读(126)  评论(0编辑  收藏  举报