Description

Farmer John goes to Dollar Days at The Cow Store and discovers an unlimited number of tools on sale. During his first visit, the tools are selling variously for $1, $2, and $3. Farmer John has exactly $5 to spend. He can buy 5 tools at $1 each or 1 tool at $3 and an additional 1 tool at $2. Of course, there are other combinations for a total of 5 different ways FJ can spend all his money on tools. Here they are: 

        1 @ US$3 + 1 @ US$2

1 @ US$3 + 2 @ US$1
1 @ US$2 + 3 @ US$1
2 @ US$2 + 1 @ US$1
5 @ US$1
Write a program than will compute the number of ways FJ can spend N dollars (1 <= N <= 1000) at The Cow Store for tools on sale with a cost of $1..$K (1 <= K <= 100).

Input

A single line with two space-separated integers: N and K.

Output

A single line with a single integer that is the number of unique ways FJ can spend his money.

Sample Input

5 3

Sample Output

5

一看完全背包, 套了模板, 很遗憾wa了, 想了想,不明所以, 搜了下题解, 居然说是因为结果太大, 看看数据似乎是这样的, 据说是两位数存就可以, 结果写完提交,果断AC
 
#include <iostream>
#include <queue>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <stack>
#include <vector>
#include <algorithm>

using namespace std;

#define N 2100
#define met(a,b) (memset(a,b,sizeof(a)))
typedef long long LL;


LL dp[N][2];

int main()
{
    int n, m;

    while(scanf("%d%d", &n, &m)!=EOF)
    {
        int i, j;

        met(dp, 0);

        dp[0][0] = 1;
        for(i=1; i<=m; i++)
        for(j=i; j<=n; j++)
        {
            dp[j][0] += dp[j-i][0];
            dp[j][1] += dp[j-i][1];
            dp[j][1] += dp[j][0]/1000000000000000;
            dp[j][0] %= 1000000000000000;
        }

        if(dp[n][1]==0)
            printf("%I64d\n", dp[n][0]);
        else
        {
            printf("%I64d%015I64d\n", dp[n][1], dp[n][0]);
        }
    }

    return 0;
}

 

 

参考http://www.cnblogs.com/kuangbin/archive/2012/09/20/2695165.html

posted on 2016-05-28 14:13  栀蓝  阅读(407)  评论(0编辑  收藏  举报

levels of contents