Buy the souvenirs

Time Limit: 10000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1904    Accepted Submission(s): 711


Problem Description
When the winter holiday comes, a lot of people will have a trip. Generally, there are a lot of souvenirs to sell, and sometimes the travelers will buy some ones with pleasure. Not only can they give the souvenirs to their friends and families as gifts, but also can the souvenirs leave them good recollections. All in all, the prices of souvenirs are not very dear, and the souvenirs are also very lovable and interesting. But the money the people have is under the control. They can’t buy a lot, but only a few. So after they admire all the souvenirs, they decide to buy some ones, and they have many combinations to select, but there are no two ones with the same kind in any combination. Now there is a blank written by the names and prices of the souvenirs, as a top coder all around the world, you should calculate how many selections you have, and any selection owns the most kinds of different souvenirs. For instance:



And you have only 7 RMB, this time you can select any combination with 3 kinds of souvenirs at most, so the selections of 3 kinds of souvenirs are ABC (6), ABD (7). But if you have 8 RMB, the selections with the most kinds of souvenirs are ABC (6), ABD (7), ACD (8), and if you have 10 RMB, there is only one selection with the most kinds of souvenirs to you: ABCD (10).
 

Input
For the first line, there is a T means the number cases, then T cases follow.
In each case, in the first line there are two integer n and m, n is the number of the souvenirs and m is the money you have. The second line contains n integers; each integer describes a kind of souvenir. 
All the numbers and results are in the range of 32-signed integer, and 0<=m<=500, 0<n<=30, t<=500, and the prices are all positive integers. There is a blank line between two cases.
 

Output
If you can buy some souvenirs, you should print the result with the same formation as “You have S selection(s) to buy with K kind(s) of souvenirs”, where the K means the most kinds of souvenirs you can buy, and S means the numbers of the combinations you can buy with the K kinds of souvenirs combination. But sometimes you can buy nothing, so you must print the result “Sorry, you can't buy anything.”
 

Sample Input
2 4 7 1 2 3 4 4 0 1 2 3 4
 

Sample Output
You have 2 selection(s) to buy with 3 kind(s) of souvenirs. Sorry, you can't buy anything.
 
题目大意:
 
一共有 n 个纪念品, 现在你有 m 金币, 告诉你 n 个纪念品的价格, 问你最多可以买多少个纪念品(Max),买最多纪念品有多少个组合(sum)
 
思路:
 
dp[i][k][j] = dp[i-1][k][j] + dp[i-1][k-1][j-a[i]]
dp[i][k][j] 代表从前 i 个纪念品中选 k 个最大价值为 j 的组合数
降维
dp[k][j] = dp[k][j] + dp[k-1][j-a[i]]
dp[k][j] 代表选 k 个最大价值为 j 的组合数
 
 
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <vector>
#include <map>
#include <algorithm>
using namespace std;

const int N = 550;
const int INF = 0x3fffffff;
const long long MOD = 1000000007;
typedef long long LL;
#define met(a,b) (memset(a,b,sizeof(a)))

int a[40];
int dp[40][N];

/// dp[k][j] 代表选 k 个物品,其中价值为 j 的物品的组合数

int main()
{
    int T;
    scanf("%d", &T);
    while(T--)
    {
        int i, j, k, n, m, Max=0;

        scanf("%d%d", &n, &m);

        met(a, 0);
        met(dp, 0);

        for(i=1; i<=n; i++)
            scanf("%d", &a[i]);

        dp[0][0] = 1;
        for(i=1; i<=n; i++)
        {
            for(k=i; k>=1; k--)
            {
                for(j=a[i]; j<=m; j++)
                {

                   dp[k][j] += dp[k-1][j-a[i]];
                   if(dp[k][j]&&(k>Max)) ///如果 dp[k][j] 有值并且 k>Max 更新Max 
                     Max = k;
                }
            }
        }

        ///Max 代表从 n 个物品中最多可以选 Max 种物品
        ///sum 代表有选 Max 个物品的总组合数
        int sum = 0;
        for(i=0; i<=m; i++)
            sum += dp[Max][i];

        if(!Max)
            printf("Sorry, you can't buy anything.\n");
        else
            printf("You have %d selection(s) to buy with %d kind(s) of souvenirs.\n", sum, Max);
    }
    return 0;
}

 

posted on 2016-05-11 09:51  栀蓝  阅读(206)  评论(0编辑  收藏  举报

levels of contents