Description

FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time. 

The treats are interesting for many reasons:
  • The treats are numbered 1..N and stored sequentially in single file in a long box that is open at both ends. On any day, FJ can retrieve one treat from either end of his stash of treats.
  • Like fine wines and delicious cheeses, the treats improve with age and command greater prices.
  • The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).
  • Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.
Given the values v(i) of each of the treats lined up in order of the index i in their box, what is the greatest value FJ can receive for them if he orders their sale optimally? 

The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.

Input

Line 1: A single integer, N 

Lines 2..N+1: Line i+1 contains the value of treat v(i)

Output

Line 1: The maximum revenue FJ can achieve by selling the treats

Sample Input

5
1
3
1
5
2

Sample Output

43

Hint

Explanation of the sample: 

Five treats. On the first day FJ can sell either treat #1 (value 1) or treat #5 (value 2). 

FJ sells the treats (values 1, 3, 1, 5, 2) in the following order of indices: 1, 5, 2, 3, 4, making 1x1 + 2x2 + 3x3 + 4x1 + 5x5 = 43.
 
 
 
题目大意:
    给出的一系列的数字,可以看成一个双向队列,每次只能从队首或者队尾出队,第n个出队就拿这个数乘以n,最后将和加起来,求最大和

思路:从外向里推,并不是很好推, 于是应该从里向外逆推区间,这样就简单多了
 
记忆化搜索:
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>
#include <iostream>
#include <cmath>
#include <queue>
using namespace std;
typedef long long LL;
#define N 2005
#define met(a,b) (memset(a,b,sizeof(a)))

int a[N], dp[N][N], n;

int DFS(int L, int R, int k)
{
    if(L>R || L<1 || R<1 || R>n || L>n) return -1;

    if(dp[L][R]!=-1)
        return dp[L][R];

    dp[L][R] = 0;
    dp[L][R] = max(DFS(L+1, R, k+1) + a[L]*k, DFS(L, R-1, k+1) + a[R]*k);

    return dp[L][R];
}

int main()
{

    while(scanf("%d", &n)!=EOF)
    {
        int i;

        met(dp, -1);
        met(a, 0);

        for(i=1; i<=n; i++)
            scanf("%d", &a[i]);

        for(i=1; i<=n; i++)
            dp[i][i] = a[i]*n;

        dp[1][n] = DFS(1, n, 1);

        printf("%d\n", dp[1][n]);
    }
    return 0;
}

 

 

#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>
#include <iostream>
#include <cmath>
#include <queue>
using namespace std;
typedef long long LL;
#define N 2005
#define met(a,b) (memset(a,b,sizeof(a)))

int a[N], dp[N][N], n;

int main()
{

    while(scanf("%d", &n)!=EOF)
    {
        int i, j, l;

        met(dp, 0);
        met(a, 0);

        for(i=1; i<=n; i++)
            scanf("%d", &a[i]);

        for(i=1; i<=n; i++)
            dp[i][i] = a[i]*n;

        for(l=1; l<n; l++)
        {
            for(i=1; i+l<=n; i++)
            {
                j = i+l;
                dp[i][j] = max(dp[i+1][j]+a[i]*(n-l), dp[i][j-1]+a[j]*(n-l));
            }
        }

        printf("%d\n", dp[1][n]);
    }
    return 0;
}

 

 

 

posted on 2016-05-07 19:57  栀蓝  阅读(146)  评论(0编辑  收藏  举报

levels of contents