ZSTUOJ刷题④:Problem B.--输出双层金字塔

Problem B: 输出双层金字塔

Time Limit: 1 Sec  Memory Limit: 64 MB
Submit: 7860  Solved: 5834

Description

输出双层金字塔

Input

输入一个大于2的整数

Output

输出n层的双层金字塔

Sample Input

2
5

Sample Output

 *
***
 *
    *
   ***
  *****
 *******
*********
 *******
  *****
   ***
    *
代码如下:
#include<bits/stdc++.h>
using namespace std;

int main(){
    int n;
    while(cin>>n){
        for(int i=1;i<=n;i++){
            for(int j=1;j<=n-i;j++){
                cout<<" ";
            }
            for(int k=1;k<=2*i-1;k++){
                cout<<"*";
            }
            cout<<endl;
        }
        for(int i=n-1;i>=1;i--){
            for(int j=1;j<=n-i;j++){
                cout<<" ";
            }
            for(int k=1;k<=2*i-1;k++){
                cout<<"*";
            }
            cout<<endl;
        } 
    }
    
    return 0;
}

 

posted @ 2021-05-17 16:44  Ta7KiXuoul  阅读(114)  评论(0编辑  收藏  举报