POJ3416(Oulipo)
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 2946 | Accepted: 1051 |
Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:
Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…
Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.
So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.
Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
- One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
- One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.
Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
Sample Input
3 BAPC BAPC AZA AZAZAZA VERDI AVERDXIVYERDIAN
Sample Output
1 3 0
/*
POJ3461(Oulipo)
Accepted 5108K 141MS C++ 901B 2009-05-10 09:48:46
by Xredman
*/
#include <iostream>
#include <cstring>
using namespace std;
const int N = 10004;
const int M = 1000005;
char S[N],//主串
T[M];//模式串
int Slen, Tlen;//主串和模式串的长度
int next[M];
void get_next()
{
int j, k;
j = 0; k = -1; next[0] = -1;
while(j < Tlen)
if(k == -1 || T[j] == T[k])
{
next[++j] = ++k;
}
else
k = next[k];
}
int KMP_Count()
{//此函数用于计算模式串在主串中出现的次数,可以交叉
int ans = 0;
int i, j = 0;
Slen = strlen(S);
Tlen = strlen(T);
if(Slen == 1 && Tlen == 1)
{
if(S[0] == T[0])
return 1;
else
return 0;
}
get_next();
for(i = 0; i < Tlen; i++)
{
while(j > 0 && S[j] != T[i])
j = next[j];
if(S[j] == T[i])
j++;
if(j == Slen)
{
ans++;
j = next[j];
}
}
return ans;
}
/*
int KMP_Index()
{//此函数用于返回模式串在主串中第一次出现的位置
//不存在返回-1
int i, j;
i = j = 0;
Slen = strlen(S); Tlen = strlen(T);
get_next();
while(i < Slen && j < Tlen)
if(j == -1 || S[i] == T[j])
{
i++; j++;
}
else
j = next[j];
if(j == Tlen)
return i - Tlen;
else
return -1;
}*/
int main()
{
int n;
scanf("%d", &n);
getchar();
while(n--)
{
scanf("%s%s", S, T);//输入主串和模式串
printf("%d\n", KMP_Count());
}
return 0;
}