HDOJ2147(kiki's game)

kiki's game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 40000/1000 K (Java/Others)
Total Submission(s): 1013    Accepted Submission(s): 598


Problem Description
Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can't make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?
 

Input
Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0.

 

Output
If kiki wins the game printf "Wonderful!", else "What a pity!".
 

Sample Input
5 3
5 4
6 6
0 0
 

Sample Output
What a pity!
Wonderful!
Wonderful!

 

 

#include <iostream>
using namespace std;

int main()
{
    
int a, b;
    
while(cin>>a>>b)
    
{
        
if(!&& !b)
            
break;
        
if(a % 2 && b % 2)
            cout
<<"What a pity!"<<endl;
        
else
            cout
<<"Wonderful!"<<endl;
    }

    
return 0;
}

posted on 2009-05-09 10:10  Xredman  阅读(231)  评论(0编辑  收藏  举报

导航