HDOJ1081(To The Max)

To The Max

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1049    Accepted Submission(s): 438


Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.
 

Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
 

Output
Output the sum of the maximal sub-rectangle.
 

Sample Input
4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1
8 0 -2
Sample Output
15
 
//20:15:45 Accepted 1081 15MS 300K 787 B C++ Xredman 
#include <iostream>
using namespace std;

const int N = 102;

int n;
int matrix[N][N];

int maxSum(int *str)
{
    
int k,result,tsum;
    tsum 
= result = str[0];
    
for(int i = 1; i < n; i++)
    
{
        tsum 
+= str[i];
        
if(result < tsum)
            result 
= tsum;
        
if(tsum < 0)
            tsum 
= 0;
    }

    
return result;
}


int main()
{
    
int i, j, k;
    
int b[N];
    
int ans , tmax;
    
while(scanf("%d"&n) != EOF)
    
{
        
for(i = 0; i < n; i++)
            
for(j = 0; j < n; j++)
                scanf(
"%d"&matrix[i][j]);
        ans 
= INT_MIN;
        
for(k = 0; k < n; k++)
        
{
            
for(i = 0; i < n; i++)
                b[i] 
= 0;
            
for(i = k; i < n; i++)
            
{
                
for(j = 0; j < n; j++)
                    b[j] 
+= matrix[i][j];
                tmax 
= maxSum(b);
                
if(tmax > ans)
                    ans 
= tmax;
            }

        }

        cout
<<ans<<endl;
    }

    
return 0;
}

posted on 2009-04-20 20:19  Xredman  阅读(349)  评论(0编辑  收藏  举报

导航