HDOJ2141(Can you find it?)
Can you find it?
Time Limit: 10000/3000 MS (Java/Others) Memory Limit: 32768/10000 K (Java/Others)Total Submission(s): 888 Accepted Submission(s): 182
Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
Sample Input
3 3 3 1 2 3 1 2 3 1 2 3 3 1 4 10
Sample Output
Case 1: NO YES NO
#include <iostream>
#include <algorithm>
using namespace std;
const int N = 502;
__int64 A[N],B[N],AB[N * N],C[N];
int ca, cb, cab, cc;
bool cmp(__int64 a, __int64 b)
{
return a < b;
}
void meso()
{
int i, j, k = 0;
cab = ca * cb;
for(i = 0; i < ca; i++)
for(j = 0; j < cb; j++)
AB[k++] = A[i] + B[j];
sort(AB, AB + cab, cmp);
}
bool search(__int64 TX)
{
int low = 0, high = cab - 1, mid;
while(low <= high)
{
mid = (low + high) / 2;
if(TX == AB[mid])
return true;
else if(TX < AB[mid])
high = mid - 1;
else low = mid + 1;
}
return false;
}
int main()
{
int i,S, kk = 1;
bool flag;
__int64 X, TX;
while(cin>>ca>>cb>>cc)
{
for(i = 0; i < ca; i++)
scanf("%I64d",A + i);
for(i = 0; i < cb; i++)
scanf("%I64d",B + i);
for(i = 0; i < cc; i++)
scanf("%I64d",C + i);
meso();
cout<<"Case "<<kk++<<":"<<endl;
cin>>S;
while(S--)
{
scanf("%I64d", &X);
flag = false;
for(i = 0; i < cc; i++)
{
TX = X - C[i];
if(search(TX))
{
flag = true;
break;
}
}
if(flag)
cout<<"YES"<<endl;
else
cout<<"NO"<<endl;
}
}
return 0;
}
#include <algorithm>
using namespace std;
const int N = 502;
__int64 A[N],B[N],AB[N * N],C[N];
int ca, cb, cab, cc;
bool cmp(__int64 a, __int64 b)
{
return a < b;
}
void meso()
{
int i, j, k = 0;
cab = ca * cb;
for(i = 0; i < ca; i++)
for(j = 0; j < cb; j++)
AB[k++] = A[i] + B[j];
sort(AB, AB + cab, cmp);
}
bool search(__int64 TX)
{
int low = 0, high = cab - 1, mid;
while(low <= high)
{
mid = (low + high) / 2;
if(TX == AB[mid])
return true;
else if(TX < AB[mid])
high = mid - 1;
else low = mid + 1;
}
return false;
}
int main()
{
int i,S, kk = 1;
bool flag;
__int64 X, TX;
while(cin>>ca>>cb>>cc)
{
for(i = 0; i < ca; i++)
scanf("%I64d",A + i);
for(i = 0; i < cb; i++)
scanf("%I64d",B + i);
for(i = 0; i < cc; i++)
scanf("%I64d",C + i);
meso();
cout<<"Case "<<kk++<<":"<<endl;
cin>>S;
while(S--)
{
scanf("%I64d", &X);
flag = false;
for(i = 0; i < cc; i++)
{
TX = X - C[i];
if(search(TX))
{
flag = true;
break;
}
}
if(flag)
cout<<"YES"<<endl;
else
cout<<"NO"<<endl;
}
}
return 0;
}