Integer Factorization
Problem C:Integer Factorization
Time Limit:2000MS Memory Limit:65536K
Total Submit:235 Accepted:127
Description
问题描述:
大于1 的正整数n可以分解为:n=X1*X2*…*Xm。
例如,当n=12 时,共有8 种不同的分解式:
12=12;
12=6*2;
12=4*3;
12=3*4;
12=3*2*2;
12=2*6;
12=2*3*2;
12=2*2*3。
编程任务:
对于给定的正整数n,编程计算n共有多少种不同的分解式。
Input
输入由多组测试数据组成。
每组测试数据输入第一行有1 个正整数n (1≤n≤2000000000)。
Output
对应每组输入,输出计算出的不同的分解式数。
Sample Input
12
Sample Output
8
照着学长的思路,第一次亦步亦趋的写下了我的第一个记忆化搜索程序。照本人的理解,所谓记忆化搜索,就是每dfs一次,可以解出另外问题的解,而此法的优点就是每次把求得解及时记录下来,以备下次使用。
#include <iostream>
#include <cmath>
#include <map>
using namespace std;
map<int,int> cnt;
int dfs(int n)
{
int tt, result = 0, j;
if(cnt[n])
return cnt[n];
tt = sqrt((double)n);//这应当是第一精华所在
for(int i = 1; i <= tt; i++)
{
if(n % i == 0)
{
if(cnt[i])
result += cnt[i];
else
result += dfs(i);
j = n / i;
if(j != i && j != n)
{//这里也得好好理解
if(cnt[j])
result += cnt[j];
else
result += dfs(j);
}
}
}
cnt[n] = result;
return cnt[n];
}
int main()
{
int n;
cnt.clear();
cnt[1] = 1;
cnt[2] = 1;
while(cin>>n)
{
cout<<dfs(n)<<endl;
}
return 0;
}
#include <cmath>
#include <map>
using namespace std;
map<int,int> cnt;
int dfs(int n)
{
int tt, result = 0, j;
if(cnt[n])
return cnt[n];
tt = sqrt((double)n);//这应当是第一精华所在
for(int i = 1; i <= tt; i++)
{
if(n % i == 0)
{
if(cnt[i])
result += cnt[i];
else
result += dfs(i);
j = n / i;
if(j != i && j != n)
{//这里也得好好理解
if(cnt[j])
result += cnt[j];
else
result += dfs(j);
}
}
}
cnt[n] = result;
return cnt[n];
}
int main()
{
int n;
cnt.clear();
cnt[1] = 1;
cnt[2] = 1;
while(cin>>n)
{
cout<<dfs(n)<<endl;
}
return 0;
}