BZOJ 1816: [Cqoi2010]扑克牌【二分】
1816: [Cqoi2010]扑克牌
Time Limit: 10 Sec Memory Limit: 64 MB
Description
你有n种牌,第i种牌的数目为ci。另外有一种特殊的牌:joker,它的数目是m。你可以用每种牌各一张来组成一套牌,也可以用一张joker和除了某一种牌以外的其他牌各一张组成1套牌。比如,当n=3时,一共有4种合法的套牌:{1,2,3}, {J,2,3}, {1,J,3}, {1,2,J}。 给出n, m和ci,你的任务是组成尽量多的套牌。每张牌最多只能用在一副套牌里(可以有牌不使用)。
Input
第一行包含两个整数n, m,即牌的种数和joker的个数。第二行包含n个整数ci,即每种牌的张数。
Output
输出仅一个整数,即最多组成的套牌数目。
Sample Input
3 4
1 2 3
Sample Output
3
样例解释
输入数据表明:一共有1个1,2个2,3个3,4个joker。最多可以组成三副套牌:{1,J,3}, {J,2,3}, {J,2,3},joker还剩一个,其余牌全部用完。
数据范围
50%的数据满足:2 < = n < = 5, 0 < = m < = 10^ 6, 0< = ci < = 200
100%的数据满足:2 < = n < = 50, 0 < = m, ci < = 500,000,000。
题解
这题很容易想到二分,但是要注意,每组只能放一个Joker(我被坑了很长时间QAQ)。
代码如下
#include<cstdio>
#include<algorithm>
using namespace std;
int n,m,a[55],Level;
bool check(int x){
int Now=min(x,m);
for(int i=1;i<=n;i++){
if(x>a[i]) Now-=x-a[i];
if(Now<0) return 0;
}
return 1;
}
int main(){
// freopen("prob.in","r",stdin);
// freopen("prob.out","w",stdout);
scanf("%d%d",&n,&m);
for(int i=1;i<=n;i++) scanf("%d",&a[i]);
int L=0,R=1e9;
while(L<=R){
int mid=(R-L>>1)+L;
if(check(mid)) Level=mid,L=mid+1;else R=mid-1;
}
printf("%d\n",Level);
return 0;
}