BZOJ 3293: [Cqoi2011]分金币【数学题】

3293: [Cqoi2011]分金币

Time Limit: 10 Sec Memory Limit: 128 MB

Description

圆桌上坐着n个人,每人有一定数量的金币,金币总数能被n整除。每个人可以给他左右相邻的人一些金币,最终使
得每个人的金币数目相等。你的任务是求出被转手的金币数量的最小值。

Input

第一行为整数n(n>=3),以下n行每行一个正整数,按逆时针顺序给出每个人拥有的金币数。
3<=N<=100000,总金币数<=10^9

Output
输出被转手金币数量的最小值

Sample Input

4
1
2
5
4

Sample Output

4

样例解释

设四个人编号为1,2,3,4。第3个人给第2个人2个金币(变成1,4,3,4),第2个人和第4个人分别给第1个人1个金币。

题解

可以看我另一篇博客,一模一样的想法https://blog.csdn.net/qq_41357771/article/details/79068704

代码如下

#include<cstdio>
#include<algorithm>
using namespace std;
int n;long long Ans,a[100005],Sum;
long long _abs(long long x){return x<0?-x:x;}
int main(){
    #ifndef ONLINE_JUDGE
    freopen("prob.in","r",stdin);
    freopen("prob.out","w",stdout);
    #endif
    scanf("%d",&n);
    for(int i=1;i<=n;i++) scanf("%lld",&a[i]),Sum+=a[i];
    Sum/=n;
    for(int i=1;i<=n;i++) a[i]+=a[i-1]-Sum;
    sort(a+1,a+1+n);
    for(int i=1;i<=n;i++) Ans+=_abs(a[i]-a[(n+1)>>1]);
    printf("%lld\n",Ans);
    return 0;
}
posted @ 2018-05-03 17:30  XSamsara  阅读(180)  评论(0编辑  收藏  举报