USACO 1.5 Number Triangles

Number Triangles

Consider the number triangle shown below. Write a program that calculates the highest sum of numbers that can be passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

          7

        3   8

      8   1   0

    2   7   4   4

  4   5   2   6   5

In the sample above, the route from 7 to 3 to 8 to 7 to 5 produces the highest sum: 30.

PROGRAM NAME: numtri

INPUT FORMAT

The first line contains R (1 <= R <= 1000), the number of rows. Each subsequent line contains the integers for that particular row of the triangle. All the supplied integers are non-negative and no larger than 100.

SAMPLE INPUT (file numtri.in)

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

OUTPUT FORMAT

A single line containing the largest sum using the traversal specified.

SAMPLE OUTPUT (file numtri.out)

30

题解: 数字三角形,dp中最简单的问题
ps:本人大三狗一枚,正在持续更新博客,文章里有任何问题,希望各位网友可以指出。若有疑问也可在评论区留言,我会尽快回复。希望能与各位网友互相学习,谢谢

/*
ID: cxq_xia1
PROG: numtri
LANG: C++
*/
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
const int maxn=1002;
int a[maxn][maxn];
int dp[maxn];
int main()
{
    freopen("numtri.in","r",stdin);
    freopen("numtri.out","w",stdout);

    int R;
    memset(a,0,sizeof(a));
    memset(dp,0,sizeof(dp));
    cin >> R;

    for(int i=1;i<=R;i++)
    {
        for(int j=1;j<=i;j++)
        {
            cin >> a[i][j];
        }
    }

    for(int i=R;i>0;i--)
    {
        for(int j=1;j<=i;j++)
        {
            dp[j]=max(dp[j],dp[j+1])+a[i][j];
        }
    }
    cout << dp[1] <<endl;
    return 0;
}

  



posted on 2015-09-11 14:47  ArcherCheng  阅读(135)  评论(0编辑  收藏  举报