02-线性结构4 Pop Sequence (25分)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.
Input Specification:
Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.
Output Specification:
For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.
Sample Input:
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2
Sample Output:
YES
NO
NO
YES
NO

解题思想:
1:将输入的N个值放在数组data[]中,然后将数组作为函数参数传给checkcheck_stack(),并且在checkcheck_stack()函数中创建一个栈ptr,依次入栈1-N的值。
2:check_stack中主要判断三个条件:
top(ptr)->data[index]:ptr的栈顶元素小于data[index];
ptr->top+1 < capacity :ptr的容量不超过M个;
index != N:比较次数不超过data[]中的元素个数;
3:若ptr中栈顶元素=data[index],则Pop出ptr栈顶元素,并将index+1。

代码如下:

#include <iostream>
#include <stdlib.h>
using namespace std;
#define maxlen 1000
typedef struct node{
    int data[maxlen];
    int capacity;
    int top;
}stack;
int M,N,K;
stack *create_stack(){
    stack *ptr = (stack*)malloc(sizeof(struct node));
    ptr->capacity = maxlen;
    ptr->top = -1;
    return ptr;
}
void push(stack *ptr, int num){
    if(ptr->top == ptr->capacity -1){
        cout<<"Full";
        return;
    }
    ptr->top++;
    ptr->data[ptr->top] = num;
}
int top(stack *ptr){
    return ptr->data[ptr->top];
}
void pop(stack *ptr){
    if(ptr->top == -1){
        cout<<"Empty";
        return;
    }
    ptr->top--;

}
int check_stack(int data[]){
    int capacity = M+1;
    stack *ptr = create_stack();
    push(ptr,0);
    int index = 0;
    int num = 1;
    while(index != N){
        while(top(ptr)<data[index] && ptr->top+1 < capacity && index != N){
            push(ptr,num++);
        }
        if(top(ptr) == data[index]){
            pop(ptr);
            index++;
        }else
            return false;
    }
    return true;
}
int main(){
    cin>>M>>N>>K;
    int dat[N];
    int i;
    for(;K!=0;--K){
        for(i = 0; i < N; i++){
            cin>>dat[i];
        }
        if(check_stack(dat)){
            cout<<"YES"<<endl;
        }else{
            cout<<"NO"<<endl;
        }
    }
    return 0;
}
posted @ 2017-11-02 21:33  Western_Trail  阅读(114)  评论(0编辑  收藏  举报