HDU-2054

A == B ?
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 118290 Accepted Submission(s): 18873

Problem Description
Give you two numbers A and B, if A is equal to B, you should print “YES”, or print “NO”.

Input
each test case contains two numbers A and B.

Output
for each case, if A is equal to B, you should print “YES”, or print “NO”.

Sample Input
1 2
2 2
3 3
4 3

Sample Output
NO
YES
YES
NO

解题心得:

很典型的一道大数问题,不过不涉及大数的运算,所以不是特别难。大数问题常规套路是用字符数组存储输入数据。本题就是比较输入的两个大数是否相等,可以用strcmp解决。但是要注意处理4.003和4.0030000这种有多余0的情况,水题。

代码:

#include <iostream>
#include <string.h>
using namespace std;

void abs(char a[])
{
    int len = strlen(a);
    if(strstr(a,"."))   //如果传入的是小数 
    {
        for(int i = len-1;a[i]=='0';i--)        //从尾部进行循环处理 
        {
            a[i] = '\0';
            len--;
        }
    }
    if(a[len-1]=='.')       //注意10.和10 
    {
        a[len-1] = '\0';
        len--;      
    }
}
int main()
{
    char A[1000000],B[1000000];
    while(cin>>A>>B)
    {
        abs(A);     //对类似4.00030000 4.003这种情况处理,消除多余的0; 
        abs(B);

        if(strcmp(A,B)==0)
            cout<<"YES"<<endl;
        else
            cout<<"NO"<<endl;
    }
    return 0;
}

/*用到了两个常用函数:strstr()与strcmp():
strstr(“处理字符串”,”搜索字符串(字符)”),功能是在处理字符串中寻找搜索字符串,并返回搜索字符串,否则返回null。本题中用来判断是否为小数。很方便.
strcmp(字符串1,字符串2),功能是比较两个字符串是否相等,包括长度相等内容相同,返回0:说明相等,返回<0:说明串1<串2,返回>0说明串2>串1.
这两个函数在处理大数问题中经常用到。
*/

posted @ 2018-02-12 13:24  Western_Trail  阅读(94)  评论(0编辑  收藏  举报