[YTU](1661) Fibonacci Again --模运算

1661: Fibonacci Again

Time Limit: 1 Sec  Memory Limit: 64 MB
Submit: 33  Solved: 21
[Submit][Status][Web Board]

Description

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2)

Input

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000)

Output

Print the word "yes" if 3 divide evenly into F(n). Print the word "no" if not.

Sample Input

0
1
2
3
4
5

Sample Output

no
no
yes
no
no
no


AC代码:
#include<iostream>
using namespace std;
long long f[1000005];
int main()
{
    f[0]=7;
    f[1]=11;
    for(int i=2;i<1000000;i++)
    {
        f[i]=(f[i-1]%3+f[i-2]%3)%3;
    }
    int n;
    while(cin>>n)
    {
        if(f[n]==0)
            cout<<"yes"<<endl;
        else
            cout<<"no"<<endl;
    }
    return 0;
}
解题思路:如果直接算出所有的斐波那契数列,那么当数据还没到达1000000这个极限,即使用long long,数据也会爆掉。又因为这道题要求可以整除3,即mod(3),那么我们可以用到模运算的知识进行优化:
模运算知识 :
(a*b)%m = [(a%m)*(b%m)]%m 
(a+b)%m = (a%m+b%m)%m
在斐波那契数列的递推运算过程中,进行模运算,这样就不存在数据超限的问题了。
posted @ 2017-08-04 20:46  WangMeow  阅读(148)  评论(0编辑  收藏  举报