[POJ](2975)Nim ---Nim博弈(博弈)

Nim
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6083   Accepted: 2884

Description

Nim is a 2-player game featuring several piles of stones. Players alternate turns, and on his/her turn, a player’s move consists of removing one or more stones from any single pile. Play ends when all the stones have been removed, at which point the last player to have moved is declared the winner. Given a position in Nim, your task is to determine how many winning moves there are in that position.

A position in Nim is called “losing” if the first player to move from that position would lose if both sides played perfectly. A “winning move,” then, is a move that leaves the game in a losing position. There is a famous theorem that classifies all losing positions. Suppose a Nim position contains n piles having k1k2, …, kn stones respectively; in such a position, there are k1 + k2 + … + kn possible moves. We write each ki in binary (base 2). Then, the Nim position is losing if and only if, among all the ki’s, there are an even number of 1’s in each digit position. In other words, the Nim position is losing if and only if the xor of the ki’s is 0.

Consider the position with three piles given by k1 = 7, k2 = 11, and k3 = 13. In binary, these values are as follows:

 111
1011
1101
 

There are an odd number of 1’s among the rightmost digits, so this position is not losing. However, suppose k3 were changed to be 12. Then, there would be exactly two 1’s in each digit position, and thus, the Nim position would become losing. Since a winning move is any move that leaves the game in a losing position, it follows that removing one stone from the third pile is a winning move when k1 = 7, k2 = 11, and k3 = 13. In fact, there are exactly three winning moves from this position: namely removing one stone from any of the three piles.

Input

The input test file will contain multiple test cases, each of which begins with a line indicating the number of piles, 1 ≤ n ≤ 1000. On the next line, there are n positive integers, 1 ≤ ki ≤ 1, 000, 000, 000, indicating the number of stones in each pile. The end-of-file is marked by a test case with n = 0 and should not be processed.

Output

For each test case, write a single line with an integer indicating the number of winning moves from the given Nim position.

Sample Input

3
7 11 13
2
1000000000 1000000000
0

Sample Output

3
0


解题新知:

①:尼姆博弈(Nim Game):有若干堆物品,每堆物品的个数是有限的,双方轮流从中取物品,每一次只能从一堆物品中取部分或全部物品,最少取一件,取到最后一件物品的人获胜。 
结论:把每堆物品数全部异或起来,如果得到的值为0,那么先手必败,否则先手必胜。

②:下面两个是讲解Nim算法的不错的文章:

⑴.http://www.cnblogs.com/easonliu/p/4472541.html

⑵.http://www.hankcs.com/program/algorithm/poj-2975-nim.html


第二篇讲解了这道题如何确定必胜态,自己也是差不多明白了原理……


AC代码:

#include<iostream>
using namespace std;
int main()
{
    int n;
    while(cin>>n &&n)
    {
        int a[1005];
        int sum=0;
        int flag=0;
        for(int i=1;i<=n;i++)
        {
            cin>>a[i];
            flag^=a[i];
        }
        for(int i=1;i<=n;i++)
        {
            if(a[i]>(flag^a[i]))
                sum++;
        }
        cout<<sum<<endl;
    }
    return 0;
}


posted @ 2017-08-17 14:06  WangMeow  阅读(203)  评论(0编辑  收藏  举报