[POJ](2506)Tiling ---递推+Java大数

Tiling
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 10510   Accepted: 4891

Description

In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles? 
Here is a sample tiling of a 2x17 rectangle. 

Input

Input is a sequence of lines, each line containing an integer number 0 <= n <= 250.

Output

For each line of input, output one integer number in a separate line giving the number of possible tilings of a 2xn rectangle. 

Sample Input

2
8
12
100
200

Sample Output

3
171
2731
845100400152152934331135470251
1071292029505993517027974728227441735014801995855195223534251


解题新知:

       ①:递推过程,当最左边只有一根竖的2x1,那么剩下的方案数是f[i-1];当最左边只有一个2x2时,那么剩下的方案数是f[i-2];当最左边只有两根横的2x1时,那么剩下的方案数是f[i-2];即f[i]=f[i-1]+2*f[i-2];

       :注意,f[0]=1,这点实际意义不好懂,那么反推,f[1]=1,f[2]=3,即2*f[0]=(f[2]-f[1])  f[0]=1;



AC代码:

import java.math.*;
import java.util.*;
public class Main {
	public static void main(String[] args) {
		Scanner in = new Scanner(System.in);
		BigInteger[] f = new BigInteger[1005];
		f[0] = BigInteger.ONE;
		f[1] = BigInteger.ONE;
		BigInteger b = new BigInteger("2");
		for(int i=2;i<=300;i++) {
			f[i]=f[i-1].add(f[i-2].multiply(b));
		}
		while(in.hasNextInt()) {
			int n = in.nextInt();
			System.out.println(f[n]);
		}
	}
}


posted @ 2017-09-02 17:18  WangMeow  阅读(209)  评论(0编辑  收藏  举报