[SDUT](1138)数据结构上机测试2-1:单链表操作A ---链表操作(线性表)

数据结构上机测试2-1:单链表操作A

Time Limit: 1000MS Memory Limit: 4096KB

Problem Description

输入n个整数,先按照数据输入的顺序建立一个带头结点的单链表,再输入一个数据m,将单链表中的值为m的结点全部删除。分别输出建立的初始单链表和完成删除后的单链表。

Input

第一行输入数据个数n;
第二行依次输入n个整数;
第三行输入欲删除数据m。

Output

第一行输出原始单链表的长度;
第二行依次输出原始单链表的数据;
第三行输出完成删除后的单链表长度;
第四行依次输出完成删除后的单链表数据。

Example Input

10
56 25 12 33 66 54 7 12 33 12
12

Example Output

10
56 25 12 33 66 54 7 12 33 12
7
56 25 33 66 54 7 33

Hint


解题新知:
坑点:注意对末尾节点的操作,防止指针越界。

AC代码:
#include<iostream>
#include<cstdio>
#include<cstdlib>
using namespace std;
typedef struct Node
{
    int length;
    int data;
    struct Node *next;
}node;
void creatLinklist(node * &L,int n)
{
    int d;
    node *s;
    node *now;
    L = (node *)malloc(sizeof(node));
    now = L;
    L->length = n;
    for(int i=0;i<n;i++)
    {
        scanf("%d",&d);
        s = (node *)malloc(sizeof(node));
        s->data = d;
        now->next = s;
        now = s;
    }
    now->next = NULL;
}
void LinklistDelete(node * &L,int key)
{
    node *p = L;
    node *q;
    while(p->next!=NULL)
    {
        if((p->next)->data == key)
        {
            q = p->next;
            p->next = q->next;
            free(q);
            L->length--;
        }
        else
            p = p->next;
    }
}
void print(node *L)
{
    node *p = L->next;
    printf("%d\n",L->length);
    while(p!=NULL)
    {
        if(p->next!=NULL)
            printf("%d ",p->data);
        else
            printf("%d\n",p->data);
        p = p->next;
    }
}
int main()
{
    node *L;
    int n;
    int key;
    scanf("%d",&n);
    creatLinklist(L,n);
    scanf("%d",&key);
    print(L);
    LinklistDelete(L,key);
    print(L);
    return 0;
}


/***************************************************
Result: Accepted
Take time: 0ms
Take Memory: 192KB
****************************************************/


posted @ 2017-09-08 17:12  WangMeow  阅读(299)  评论(0编辑  收藏  举报