[SDUT](2119)数据结构实验之链表四:有序链表的归并 ---有序表归并(线性表)

数据结构实验之链表四:有序链表的归并

Time Limit: 1000MS Memory Limit: 65536KB

Problem Description

分别输入两个有序的整数序列(分别包含M和N个数据),建立两个有序的单链表,将这两个有序单链表合并成为一个大的有序单链表,并依次输出合并后的单链表数据。

Input

第一行输入M与N的值; 
第二行依次输入M个有序的整数;
第三行依次输入N个有序的整数。

Output

输出合并后的单链表所包含的M+N个有序的整数。

Example Input

6 5
1 23 26 45 66 99
14 21 28 50 100

Example Output

1 14 21 23 26 28 45 50 66 99 100


AC代码:

#include<iostream>
#include<cstdio>
#include<cstdlib>
using namespace std;
typedef struct Node
{
    int data;
    struct Node *next;
}node;
void creatLinklist(node * &L,int n)
{
    node *s;
    node *now;
    L = (node *)malloc(sizeof(node));
    now = L;
    int d;
    for(int i=1;i<=n;i++)
    {
        scanf("%d",&d);
        s = (node *)malloc(sizeof(node));
        s->data = d;
        now->next = s;
        now = s;
    }
    now->next = NULL;
}
void mergesort(node *l1, node *l2, node * &lc) //二路归并算法
{
    node *now;
    node *s;
    node *p1 = l1->next;
    node *p2 = l2->next;
    lc = (node *)malloc(sizeof(node));
    now = lc;
    while(p1!=NULL && p2!=NULL)
    {
        if(p1->data < p2->data)
        {
            s = (node *)malloc(sizeof(node));
            s->data = p1->data;
            now->next = s;
            now = s;
            p1 = p1->next;
        }
        else
        {
            s = (node *)malloc(sizeof(node));
            s->data = p2->data;
            now->next = s;
            now = s;
            p2 = p2->next;
        }
    }
    while(p1!=NULL)
    {
        s = (node *)malloc(sizeof(node));
        s->data = p1->data;
        now->next = s;
        now = s;
        p1 = p1->next;
    }
    while(p2!=NULL)
    {
        s = (node *)malloc(sizeof(node));
        s->data = p2->data;
        now->next = s;
        now = s;
        p2 = p2->next;
    }
    now->next = NULL;
}
void print(node *L)
{
    node *p = L->next;
    while(p!=NULL)
    {
        if(p->next!=NULL)
            printf("%d ",p->data);
        else
            printf("%d\n",p->data);
        p = p->next;
    }
}
int main()
{
    int m;
    int n;
    node *l1;
    node *l2;
    node *lc;
    scanf("%d %d",&m,&n);
    creatLinklist(l1,m);
    creatLinklist(l2,n);
    mergesort(l1,l2,lc);
    print(lc);
    return 0;
}



posted @ 2017-09-15 16:54  WangMeow  阅读(324)  评论(0编辑  收藏  举报