hdu4349 Xiao Ming's Hope
Xiao Ming's Hope
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Problem Description
Xiao Ming likes counting numbers very much, especially he is fond of counting odd numbers. Maybe he thinks it is the best way to show he is alone without a girl friend. The day 2011.11.11 comes. Seeing classmates walking with their girl friends, he coundn't help running into his classroom, and then opened his maths book preparing to count odd numbers. He looked at his book, then he found a question "C(n,0)+C(n,1)+C(n,2)+...+C(n,n)=?". Of course, Xiao Ming knew the answer, but he didn't care about that , What he wanted to know was that how many odd numbers there were? Then he began to count odd numbers. When n is equal to 1, C(1,0)=C(1,1)=1, there are 2 odd numbers. When n is equal to 2, C(2,0)=C(2,2)=1, there are 2 odd numbers...... Suddenly, he found a girl was watching him counting odd numbers. In order to show his gifts on maths, he wrote several big numbers what n would be equal to, but he found it was impossible to finished his tasks, then he sent a piece of information to you, and wanted you a excellent programmer to help him, he really didn't want to let her down. Can you help him?
Input
Each line contains a integer n(1<=n<=108)
Output
A single line with the number of odd numbers of C(n,0),C(n,1),C(n,2)...C(n,n).
Sample Input
1
2
11
Sample Output
2
2
8
Author
HIT
Source
Recommend
zhuyuanchen520 | We have carefully selected several similar problems for you: 4340 4348 4347 4346 4345
Tips:
题意:给定一个数n,求所有C(n,0),C(n,1),C(n,2)......C(n,n)中奇数的个数;
其实这题就是lucas定理的应用;
C(n,m)%2 (m<=n);
如果 n=(10010101)2,那么m就是00000000到10010101;
C(1,0)=1; C(0,1)=1; C(1,1)=1;
所以n的某一位是1,m的那一位上是0,1都行;
所以只要知道n有多少位是1就行了;
Code:
#include<cstdio> #include<algorithm> #include<cstring> #include<iostream> using namespace std; long long flag,ans,n; int main(){ while(scanf("%lld",&n)!=EOF){ ans=1; while(n>0){ flag=n%2; if(flag==1) ans*=2; n=n/2; } printf("%lld\n",ans); } }