比较两个数字是否相等 杭电2054

Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".

 

 

Input
each test case contains two numbers A and B.
 

 

Output
for each case, if A is equal to B, you should print "YES", or print "NO".
 

 

Sample Input
1 2 2 2 3 3 4 3
 

 

Sample Output
NO YES YES NO

 

#include<stdio.h>
#include<string.h>
int main()
{
char a[100000],b[100000];
while(scanf("%s%s",&a,&b)!=EOF)
{
int i;
if (strchr(a,'.'))
{
for(i=strlen(a)-1;a[i]=='0';i--)
a[i]='\0';
if(a[i]=='.')
a[i]='\0';
}
if(strchr(b,'.'))//这个函数的意思是找到你想找到的东西,并返回它的地址
{
for(i=strlen(b)-1;b[i]=='0';i--)
b[i]='\0';
if(b[i]=='.')
b[i]='\0';//挺有意思的
}
if(strcmp(a,b)==0)//比较两个数组的大小
printf("YES\n");
else
printf("NO\n");
}
return 0;
}

posted @ 2016-01-22 18:56  一点绝不是微小  阅读(321)  评论(0编辑  收藏  举报