安迪的第一个字典(Andy's First Dictionary , UVa 10815)

输入一个文本,找出所有不同的单词(连续的字母序列),按字典序从小到大输出。

单词不区分大小写。

样例输入:

Adventures in Disneyland

Two blondes were going to Disneyland when they came to a fork in the road.

The sign read: "Disneyland Left."

So they went home.

样例输出(为了节省篇幅只保留前5行):

a

adventures

blondes

came

disneyland

 

分析:由于string 已经定义了小于运算符,直接使用set保存单词集合即可

注意,输入时把所有非字母的字符变成空格,然后利用stringstream得到各个单词

代码如下

复制代码
#include<iostream>
#include<string>
#include<set>
#include<sstream>
using namespace std;

set<string> dict;//string集合

int main(){
    string s,buf;
    while(cin>>s){
        for(int i=0;i<s.length();i++){
            if(isalpha(s[i])){
                s[i] = tolower(s[i]);
            }else{
                s[i]=' ';
            }
        }
        stringstream ss(s);
        while(ss >> buf) dict.insert(buf); //插入到set中后就已经有序了
    }
    for(set<string>::iterator it = dict.begin();it != dict.end(); ++it){
        cout<< *it <<"\n";
    }
    return 0;
} 
复制代码

 

posted @   Vincent-yuan  阅读(143)  评论(0编辑  收藏  举报
编辑推荐:
· AI与.NET技术实操系列:基于图像分类模型对图像进行分类
· go语言实现终端里的倒计时
· 如何编写易于单元测试的代码
· 10年+ .NET Coder 心语,封装的思维:从隐藏、稳定开始理解其本质意义
· .NET Core 中如何实现缓存的预热?
阅读排行:
· 分享一个免费、快速、无限量使用的满血 DeepSeek R1 模型,支持深度思考和联网搜索!
· 基于 Docker 搭建 FRP 内网穿透开源项目(很简单哒)
· 25岁的心里话
· ollama系列01:轻松3步本地部署deepseek,普通电脑可用
· 按钮权限的设计及实现
点击右上角即可分享
微信分享提示