HDU1028(母函数入门题+模板)
母函数早就想解决这个问题了,今天终于看明白模板了(自己理解这写的,虽然不对看标准改对的,但...)
Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.
"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
Sample Input
4
10
20
Sample Output
5
42
627
1 #include<stdio.h> 2 int save[150],temp[150]; 3 int main() 4 { 5 int n; 6 while(~scanf("%d",&n)) 7 { 8 for(int i=0;i<=n;i++) 9 { 10 save[i]=1; 11 temp[i]=0; 12 } 13 for(int i=2;i<=n;i++){ 14 for(int j=0;j<=n;j++) 15 for(int k=0;k+j<=n;k+=i) 16 temp[k+j]+=save[j]; 17 for(int k=0;k<=n;k++) 18 { 19 save[k]=temp[k]; 20 temp[k]=0; 21 } 22 } 23 printf("%d\n",save[n]); 24 } 25 }
有个人的母函数讲解的很好哦(就是有点问题)我会转一下的