//目录

POJ 3694 无向图的桥

Network
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 10404   Accepted: 3873

Description

A network administrator manages a large network. The network consists of N computers and M links between pairs of computers. Any pair of computers are connected directly or indirectly by successive links, so data can be transformed between any two computers. The administrator finds that some links are vital to the network, because failure of any one of them can cause that data can't be transformed between some computers. He call such a link a bridge. He is planning to add some new links one by one to eliminate all bridges.

You are to help the administrator by reporting the number of bridges in the network after each new link is added.

Input

The input consists of multiple test cases. Each test case starts with a line containing two integers N(1 ≤ N ≤ 100,000) and M(N - 1 ≤ M ≤ 200,000).
Each of the following M lines contains two integers A and B ( 1≤ A ≠ B ≤ N), which indicates a link between computer A and B. Computers are numbered from 1 to N. It is guaranteed that any two computers are connected in the initial network.
The next line contains a single integer Q ( 1 ≤ Q ≤ 1,000), which is the number of new links the administrator plans to add to the network one by one.
The i-th line of the following Q lines contains two integer A and B (1 ≤ A ≠ B ≤ N), which is the i-th added new link connecting computer A and B.

The last test case is followed by a line containing two zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) and Q lines, the i-th of which contains a integer indicating the number of bridges in the network after the first i new links are added. Print a blank line after the output for each test case.

Sample Input

3 2
1 2
2 3
2
1 2
1 3
4 4
1 2
2 1
2 3
1 4
2
1 2
3 4
0 0

Sample Output

Case 1:
1
0

Case 2:
2
0

Source

 
题意:
动态加边,求桥的数目,当然不能一直dfs(tarjin)。
分析:
操作是,加边后可以通过第一次的桥数目推出来,这条路上有桥,则,可能存在多条桥,还要继续DFS上去。
#include <cstdio>
#include <cstring>
#include <vector>
#include <algorithm>

using namespace std;

const int maxn = 100024;

vector<int> g[maxn];
int low[maxn],dfn[maxn];
int fa[maxn];
int bin[maxn];
int t;
int ans;
void tarjin(int u,int f) {
    low[u] = dfn[u] = ++t;
    fa[u] = f;

    for(int i = 0; i < (int)g[u].size(); i++) {
        int v = g[u][i];
        if(!dfn[v]) {
            tarjin(v,u);
            low[u] = min(low[u],low[v]);
            if(low[v]>dfn[u]) {
                bin[v]++;
                ans++;
            }
        }
        else if(f!=v) {
            low[u] = min(low[u],dfn[v]);
            if(low[v]>dfn[u]) {         //有反向边,不是桥
                bin[v]--;
                ans--;
            }
        }
    }

}

void LCR(int a,int b) {
    if(a==b)
        return;
    if(dfn[a]<dfn[b]) {
        if(bin[b]==1) {
            bin[b] = 0;
            ans--;
        }
        LCR(a,fa[b]);
    }
    else {
        if(bin[a]==1) {
            bin[a] = 0;
            ans--;
        }
        LCR(fa[a],b);
    }
}

int main()
{
    //freopen("in.txt","r",stdin);
    int n,m;
    int kase = 1;
    while(scanf("%d%d",&n,&m),n) {


        for(int i = 0; i <= n; i++)
            g[i].clear();
        t = 0;
        memset(dfn,0,sizeof(dfn));
        memset(low,0,sizeof(low));


        for(int i=0; i < m; i++) {
            int u,v;
            scanf("%d%d",&u,&v);
            g[u].push_back(v);
            g[v].push_back(u);
        }
        tarjin(1,-1);
    //    printf("%d\n",ans);

        printf("Case %d:\n",kase++);

        int q;
        scanf("%d",&q);
        while(q--) {
            int u,v;
            scanf("%d%d",&u,&v);
            LCR(u,v);
            printf("%d\n",ans);
        }
        puts("");

    }
    return 0;
}

 

posted @ 2017-08-31 10:24  小草的大树梦  阅读(115)  评论(0编辑  收藏  举报