//目录

Poj(1469),二分图最大匹配

题目链接:http://poj.org/problem?id=1469

COURSES
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 21229   Accepted: 8355

Description

Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:

  • every student in the committee represents a different course (a student can represent a course if he/she visits that course)
  • each course has a representative in the committee

Input

Your program should read sets of data from the std input. The first line of the input contains the number of the data sets. Each data set is presented in the following format:

P N
Count1 Student1 1 Student1 2 ... Student1 Count1
Count2 Student2 1 Student2 2 ... Student2 Count2
...
CountP StudentP 1 StudentP 2 ... StudentP CountP

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses �from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you抣l find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.
There are no blank lines between consecutive sets of data. Input data are correct.

Output

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

Sample Input

2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1

Sample Output

YES
NO

Source

 
题意:

给你p门课程和n个学生,一个学生可以选0门,1门,或者多门课程,现在要求一个由p个学生组成的集合,满足下列2个条件:

1.每个学生选择一个不同的课程

2.每个课程都有不同的代表

如果满足,就输出YES

分析:

做最大匹配,要是匹配数是P就是YES.

#include <stdio.h>
#include <string.h>

int p,n;
bool maps[105][305];
bool use[305];
int match[305];


bool DFS(int u)
{
    for(int i=1; i<=n; i++)
    {
        if(!use[i]&&maps[u][i])
        {
            use[i] = true;
            if(match[i]==-1||DFS(match[i]))
            {
                match[i] = u;
                return true;
            }
        }
    }
    return false;
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        memset(match,-1,sizeof(match));
        memset(maps,false,sizeof(maps));
        scanf("%d%d",&p,&n);
        int num = 0;
        for(int i=1; i<=p; i++)
        {
            int stu;
            scanf("%d",&stu);
            for(int j=1; j<=stu; j++)
            {
                int v;
                scanf("%d",&v);
                maps[i][v] = true;
            }
        }

        for(int i=1; i<=p; i++)
        {

            memset(use,false,sizeof(use));
            if(DFS(i))
                num++;
        }
        if(num==p)
            printf("YES\n");
        else printf("NO\n");

    }


    return 0;
}

 

posted @ 2016-08-11 14:17  小草的大树梦  阅读(166)  评论(0编辑  收藏  举报