DFS入门__poj1979

Red and Black
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 26944   Accepted: 14637

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13
/*题目大意:在一个矩形房间里,里面填满着红砖与黑砖,每次走动只能走黑砖位置,而不能走红砖,
 *			可以上下左右四个方向走动,现在初始位置在黑砖位置上,试问从此黑砖位置开始能够到达的砖的数量是多少
 *算法分析:从起始位置开始四个方向进行dfs,若遇到红砖位置则将此砖块换为黑砖。换砖的次数即为到达的黑砖数量 

*/

#include <iostream>
#include <cstdio>
using namespace std;

char a[25][25];
int n, m;
int dir[4][2] = {0, 1, 1, 0, 0, -1, -1, 0};				//四个方向数组 

void dfs(int x, int y, int &res) {
	a[x][y] = '#';
	res ++ ;
	for (int i = 0; i<4; i++) {
		int nx = x + dir[i][0];
		int ny = y + dir[i][1];
		if (nx>=0 && nx<n && ny>=0 && ny<m && a[nx][ny] == '.')
			dfs(nx, ny, res);
	}
}

int main() {
	
	while (cin >> m >> n && (n+m)) {
		
		memset(a, 0, sizeof(a));
		for (int i = 0; i<n; i++) {
			for (int j = 0; j<m; j++) {
				cin >> a[i][j];
			}
		}
		int res = 0;
		for (int i = 0; i<n; i++) {
			for (int j = 0; j<m; j++) {
				if (a[i][j] == '@') 
					dfs(i, j, res);
			}
		}
		cout << res << endl;
	}
	return 0;
}


posted @ 2015-11-17 18:32  Tovi  阅读(202)  评论(0编辑  收藏  举报