HDU 5723 Abandoned country

HDU 5723 Abandoned country

Time Limit: 8000/4000 MS (Java/Others) Memory Limit: > 65536/65536 K (Java/Others)
Total Submission(s): 7454 Accepted Submission(s): 1821

Problem Description
An abandoned country has n(n≤100000) villages which are numbered from 1 to n. Since abandoned for a long time, the roads need to be re-built. There are m(m≤1000000) roads to be re-built, the length of each road is wi(wi≤1000000). Guaranteed that any two wi are different. The roads made all the villages connected directly or indirectly before destroyed. Every road will cost the same value of its length to rebuild. The king wants to use the minimum cost to make all the villages connected with each other directly or indirectly. After the roads are re-built, the king asks a men as messenger. The king will select any two different points as starting point or the destination with the same probability. Now the king asks you to tell him the minimum cost and the minimum expectations length the messenger will walk.

Input
The first line contains an integer T(T≤10) which indicates the number of test cases.

For each test case, the first line contains two integers n,m indicate the number of villages and the number of roads to be re-built. Next m lines, each line have three number i,j,wi, the length of a road connecting the village i and the village j is wi.

Output
output the minimum cost and minimum Expectations with two decimal places. They separated by a space.

Sample Input

1

4 6

1 2 1

2 3 2

3 4 3

4 1 4

1 3 5

2 4 6

Sample Output

6 3.33

Author

HIT

题目解析

题面可能有些问题,但是直接kruskal,然后求期望就行了,期望等于 每条边经过的次数 * 该边的权值累加。每条边经过的次数等于 子节点个数(包含自身) * (n - 子节点个数(包含自身)。当然用dp也能做,可能会麻烦一点

代码

#include<bits/stdc++.h>
#define CLR(a,b) memset(a,b,sizeof(a))
using namespace std;
typedef long long ll;
const int maxn = 1e5 + 10;
struct Edge
{
    int from,to,v;
}edge[maxn*10];
int fa[maxn],vis[maxn],num[maxn];
int n,m;
ll sum;
vector<Edge> edge0[maxn];

int find(int x)
{
    return fa[x] == x ? x : fa[x] = find(fa[x]);
}

bool cmp(Edge a, Edge b)
{
    return a.v <b.v;
}

ll kruskal()
{
    for(int i = 1; i <= n; i++) fa[i] = i;
    sort(edge+1,edge+m+1,cmp);
    ll ans = 0;
    int cnt = 0;
    for(int i = 1; i <= m; i++){
        int x = find(edge[i].from);
        int y = find(edge[i].to);
        if(x != y){
            fa[x] = y;
            ans += (ll)edge[i].v;
            Edge tmp;
            tmp.from = edge[i].from,tmp.to = edge[i].to,tmp.v = edge[i].v;
            edge0[edge[i].from].push_back(tmp);
            swap(tmp.from,tmp.to);
            edge0[edge[i].to].push_back(tmp);
            if(++cnt == n-1) break;
        }
    }
    return ans;
}

void dfs(int u)
{
    for(int i = 0; i < edge0[u].size(); i++){
        int v = edge0[u][i].to;
        if(vis[v]) continue;
        vis[v] = 1;
        dfs(v);
        sum += ((ll)num[v] * (n - num[v]))*edge0[u][i].v;
        num[u] += num[v];
    }
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&m);
        for(int i = 1; i <= n; i++) edge0[i].clear();
        for(int i = 1; i <= m; i++){
            scanf("%d%d%d",&edge[i].from,&edge[i].to,&edge[i].v);
        }
        printf("%lld ",kruskal());
        for(int i = 1; i <= n; i++) num[i] = 1;
        CLR(vis,0);
        sum = 0;
        dfs(1);
        printf("%.2f\n",(1.0*sum)/(((ll)n*(n-1)/2.0)));
    }
    return 0;
}
posted @ 2018-07-30 10:19  Kurumi33  阅读(156)  评论(0编辑  收藏  举报