pat 1043. Is It a Binary Search Tree (25)

1043. Is It a Binary Search Tree (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line "YES" if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or "NO" if not. Then if the answer is "YES", print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:
7
8 6 5 7 10 8 11
Sample Output 1:
YES
5 7 6 8 11 10 8
Sample Input 2:
7
8 10 11 8 6 7 5
Sample Output 2:
YES
11 8 10 7 5 6 8
Sample Input 3:
7
8 6 8 5 10 9 11
Sample Output 3:
NO
解:先判断输入的数值是否是前序遍历的结果或者是结果的镜像;如果是,进行后序遍历,即左-右-根。

代码:

#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<vector>
using namespace std;
struct Node  //结点结构
{
    int val;
    Node *left;
    Node *right;
};

bool Is_BST(int *val,int n,Node **r)   //判断前序遍历
{
    if(val==NULL||n<=0)
    {
        return false;
    }
    *r=new Node();
    Node *root=*r;
    root->val=val[0];
    root->left=NULL;
    root->right=NULL;
    int i,j;
    for(i=1;i<n;i++)
    {
        if(val[i]>=root->val)
            break;
    }
    for(j=i;j<n;j++)
    {
        if(val[j]<root->val)
            return false;
    }
    bool left=true;
    if(i>1)
        left=Is_BST(val+1,i-1,&root->left);
    bool right=true;
    if(i<n)
        right=Is_BST(val+i,n-i,&root->right);
    return left&&right;
}
bool Is_MirrorBST(int *val,int n,Node **r)  //判断镜像前序遍历
{
 if(val==NULL||n<=0)
    {
        return false;
    }
    *r=new Node();
    Node *root=*r;
    root->val=val[0];
    root->left=NULL;
    root->right=NULL;
    int i,j;
    for(i=1;i<n;i++)
    {
        if(val[i]<root->val)
            break;
    }
    for(j=i;j<n;j++)
    {
        if(val[j]>=root->val)
            return false;
    }
    bool left=true;
    if(i>1)
        left=Is_MirrorBST(val+1,i-1,&root->left);
    bool right=true;
    if(i<n)
        right=Is_MirrorBST(val+i,n-i,&root->right);
    return left&&right;
}
bool Judge(int *val,int n,Node **root)  //总判断
{
    if(Is_BST(val,n,root))
    {
        return true;
    }
    if(Is_MirrorBST(val,n,root))
    {
        return true;
    }
    return false;
}
void PostrOrder(Node *root,vector<int> *temp) //后序遍历
{
   if(root!=NULL)
   {
       if(root->left!=NULL)
       {
           PostrOrder(root->left,temp);
       }
       if(root->right!=NULL)
       {
           PostrOrder(root->right,temp);
       }
       (*temp).push_back(root->val);
   }
}

int main()
{
    int n;
    while(scanf("%d",&n)==1)
    {
        int *val=new int[n+1];
        for(int i=0;i<n;i++)  scanf("%d",&val[i]);
        Node *root=NULL;
        if(Judge(val,n,&root))
        {
            printf("YES\n");
            vector<int> temp;
            PostrOrder(root,&temp);
            if(!temp.empty())
            {
                printf("%d",temp[0]);
                for(int i=1;i<temp.size();i++)
                {
                    printf(" %d",temp[i]);
                }
                printf("\n");
            }
        }
        else
        {
            printf("NO\n");
        }
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

posted on   Tob__yuhong  阅读(149)  评论(0编辑  收藏  举报

编辑推荐:
· 智能桌面机器人:用.NET IoT库控制舵机并多方法播放表情
· Linux glibc自带哈希表的用例及性能测试
· 深入理解 Mybatis 分库分表执行原理
· 如何打造一个高并发系统?
· .NET Core GC压缩(compact_phase)底层原理浅谈
阅读排行:
· DeepSeek火爆全网,官网宕机?本地部署一个随便玩「LLM探索」
· 开发者新选择:用DeepSeek实现Cursor级智能编程的免费方案
· 【译】.NET 升级助手现在支持升级到集中式包管理
· 独立开发经验谈:如何通过 Docker 让潜在客户快速体验你的系统
· Tinyfox 发生重大改版
点击右上角即可分享
微信分享提示