pat 1011. World Cup Betting (20)

1011. World Cup Betting (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

For example, 3 games' odds are given as the following:

 W    T    L
1.1  2.5  1.7
1.2  3.0  1.6
4.1  1.2  1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1*3.0*2.5*65%-1)*2 = 37.98 yuans (accurate up to 2 decimal places).

Input

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

Output

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input
1.1 2.5 1.7
1.2 3.0 1.6
4.1 1.2 1.1
Sample Output
T T W 37.98
解:三行三列的值,一行代表一个比赛信息,题目意思是让求最大利润,我们找每行中间最大的一个值就行了,每行的第一个值对应W,第二个对应T,第三个对应L,所以结果也很容易得出。但是第一次提交没通过,我考虑了四舍五入,测试样例是坑啊,在所给测试样例结果中最大利润应该是37.97.

代码如下:

#include<iostream>
#include<cmath>
#include<cstdlib>
#include<cstdio>
using namespace std;
int main()
{
    double a[9];
    while(cin>>a[0])
    {
        char c[3];
        double cnt=1;
        for(int i=1;i<9;i++)
        {
            cin>>a[i];
        }
        double ma[3];
        ma[0]=max(max(a[0],a[1]),a[2]);
        ma[1]=max(max(a[3],a[4]),a[5]);
        ma[2]=max(max(a[6],a[7]),a[8]);
        if(ma[0]==a[0])
        {
            c[0]='W';
            cnt*=a[0];
        }
        if(ma[0]==a[1])
        {
            c[0]='T';
            cnt*=a[1];
        }
        if(ma[0]==a[2])
        {
            c[0]='L';
            cnt*=a[2];
        }
         if(ma[1]==a[3])
        {
            c[1]='W';
            cnt*=a[1];
        }
        if(ma[1]==a[4])
        {
            c[1]='T';
            cnt*=a[4];
        }
        if(ma[1]==a[5])
        {
            c[1]='L';
            cnt*=a[5];
        }
        if(ma[2]==a[6])
        {
            c[2]='W';
            cnt*=a[6];
        }
        if(ma[2]==a[7])
        {
            c[2]='T';
            cnt*=a[7];
        }
        if(ma[2]==a[8])
        {
            c[2]='L';
            cnt*=a[8];
        }
        cout<<c[0]<<' '<<c[1]<<' '<<c[2]<<' ';
        printf("%.2lf\n",(cnt*0.65-1)*2);
    }
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

posted on 2015-07-17 15:47  Tob__yuhong  阅读(137)  评论(0编辑  收藏  举报

导航