pat 1027. Colors in Mars (20)

1027. Colors in Mars (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input

Each input file contains one test case which occupies a line containing the three decimal color values.

Output

For each test case you should output the Mars RGB value in the following format: first output "#", then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a "0" to the left.

Sample Input
15 43 71
Sample Output
#123456
解:这题意思明确,水题,但是我在这个水题上磕了好久,真丢人。最初我的代码片段是这样的。
<span style="font-family:SimSun;">        string s[3];
        for(int i=0;i<3;i++)
        {
            s[i][0]='0';
            s[i][1]='0';
            s[i][0]=a[num[i]/13];
            s[i][1]=a[num[i]%13];
        }</span>
提交一直有样例不过,当时很郁闷,我个人认为自己还是把这题意思理解透彻了的。后来问了小czy,好的吧,自己用错了,s的范围我还没给定呢,可以用s[i].push_back(char),而不可以像上面的直接用。

代码改成以下,测试通过:
#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cstring>
using namespace std;
char a[13]={'0','1','2','3','4','5','6','7','8','9','A','B','C'};
int main()
{
    int num[3];
    while(scanf("%d%d%d",&num[0],&num[1],&num[2])==3)
    {
       // char s[3][2];
        string s[3];
        for(int i=0;i<3;i++)
        {
            s[i].push_back('0');
            s[i].push_back('0');
            s[i][0]=a[num[i]/13];
            s[i][1]=a[num[i]%13];
        }
        cout<<"#";
        for(int i=0;i<3;i++)
        {
            cout<<s[i][0]<<s[i][1];
            s[i].clear();
        }
        cout<<endl;
    }
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

posted on 2015-07-18 00:15  Tob__yuhong  阅读(220)  评论(0编辑  收藏  举报

导航