pat 1007. Maximum Subsequence Sum (25)

1007. Maximum Subsequence Sum (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4

解:最大连续子序列和

代码:

#include<iostream>
#include<cstdlib>
#include<cstdio>
using namespace std;
int main()
{
    int n;
    while(scanf("%d",&n)==1)
    {
        int *a=new int[n+1];
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
        }
        int flag,left,right,sum,cursum;
        left=right=sum=0;
        sum=a[0];
        for(int i=0;i<n;i++)
        {
            if(cursum<0)
            {
                cursum=a[i];
                flag=i;
            }
            else
            {
                cursum+=a[i];
            }
            if(cursum>sum)
            {
                sum=cursum;
                left=flag;
                right=i;
            }
        }
        if(sum<0)
            printf("0 %d %d\n",a[0],a[n-1]);
        else
            printf("%d %d %d\n",sum,a[left],a[right]);
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

posted on 2015-07-24 02:04  Tob__yuhong  阅读(226)  评论(0编辑  收藏  举报

导航