poj 2478 Farey Sequence

Farey Sequence
Time Limit: 1000MS   Memory Limit: 65536K
     

Description

The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are 
F2 = {1/2} 
F3 = {1/3, 1/2, 2/3} 
F4 = {1/4, 1/3, 1/2, 2/3, 3/4} 
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5} 

You task is to calculate the number of terms in the Farey sequence Fn.

Input

There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 106). There are no blank lines between cases. A line with a single 0 terminates the input.

Output

For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn. 

Sample Input

2
3
4
5
0

Sample Output

1
3
5
9

Source

POJ Contest,Author:Mathematica@ZSU
 
题意:求2——n的欧拉函数之和
 
线性筛出欧拉函数,搞个前缀和
注意long long
#include<cstdio>
#define N 1000001 
using namespace std;
bool check[N];
int prime[N],cnt,phi[N],a;
long long sum[N];
void euler()
{
    phi[1]=1;
    for(int i=2;i<=N;i++)
    {
        if(!check[i])
        {
            prime[++cnt]=i;
            phi[i]=i-1;
        }
        for(int j=1;j<=cnt;j++)
        {
            if(i*prime[j]>N) break;
            check[i*prime[j]]=true;
            if(i%prime[j]==0)
            {
                phi[i*prime[j]]=phi[i]*prime[j];
                break;
            }
            phi[i*prime[j]]=phi[i]*(prime[j]-1);
        }
    }
}
int main()
{
    euler();
    for(int i=1;i<=N;i++) sum[i]+=sum[i-1]+1ll*phi[i];
    while(1)
    {
        scanf("%d",&a);
        if(!a) return 0;
        printf("%lld\n",sum[a]-1);
    }
}

 

 
posted @ 2017-03-22 10:35  TRTTG  阅读(194)  评论(0编辑  收藏  举报