[解题报告]10346 - Peter's Smokes

Problem B

Peter’s Smokes

Input: standard input

Output: standard output

Time Limit: 4 seconds

Memory Limit: 32 MB

 

Peter has n cigarettes. He smokes them one by one keeping all the butts. Out of k > 1 butts he can roll a new cigarette.

How many cigarettes can Peter have?

Input

Input is a sequence of lines. Each line contains two integer numbers giving the values of n and k. The input is terminated by end of file.

Output

For each line of input, output one integer number on a separate line giving the maximum number of cigarettes that Peter can have.

Sample Input

4 3
10 3
100 5

Sample Output

5
14
124

Source: University of Alberta Local Contest

就没见过这么抠的。。。

 

 

#include<stdio.h>
int main()
{
  int n,k,temp;
  int cigarette;
  while(scanf("%d%d",&n,&k)!=EOF)
  {
    cigarette=n;
    while(n/k)
    {
      cigarette+=n/k;
      n=n/k+n%k;
    }
    printf("%d\n",cigarette);
  }
  return 0;
}

 

 

 

 

posted @ 2013-02-25 16:14  三人木君  阅读(289)  评论(0编辑  收藏  举报