[解题报告]10189 - Minesweeper

 Problem B: Minesweeper 

 

The Problem

Have you ever played Minesweeper? It's a cute little game which comes within a certain Operating System which name we can't really remember. Well, the goal of the game is to find where are all the mines within a MxN field. To help you, the game shows a number in a square which tells you how many mines there are adjacent to that square. For instance, supose the following 4x4 field with 2 mines (which are represented by an * character):

*...
....
.*..
....

If we would represent the same field placing the hint numbers described above, we would end up with:

*100
2210
1*10
1110

As you may have already noticed, each square may have at most 8 adjacent squares.

The Input

The input will consist of an arbitrary number of fields. The first line of each field contains two integers n and m (0 < n,m <= 100) which stands for the number of lines and columns of the field respectively. The next n lines contains exactly m characters and represent the field. Each safe square is represented by an "." character (without the quotes) and each mine square is represented by an "*" character (also without the quotes). The first field line where n = m = 0 represents the end of input and should not be processed.

The Output

For each field, you must print the following message in a line alone:

Field #x:

Where x stands for the number of the field (starting from 1). The next n lines should contain the field with the "." characters replaced by the number of adjacent mines to that square. There must be an empty line between field outputs.

Sample Input

 

4 4
*...
....
.*..
....
3 5
**...
.....
.*...
0 0

 

Sample Output

 

Field #1:
*100
2210
1*10
1110

Field #2:
**100
33200
1*100

© 2001 Universidade do Brasil (UFRJ). Internal Contest Warmup 2001.

 

 

童年回忆啊。。。利用二维组统计也不难啊。。。

#include<stdio.h>
#define MAX_N 100
#define MAX_M 100
#define MINE -100
int main(){
  int n, m, field_num = 0;
  char square;
  int k,l,i,j;
  while(scanf("%d%d",&n,&m)!=EOF&&!(n==0&&m==0))
  {
    getchar();
    if(field_num) printf("\n");

    int field[MAX_N+5][MAX_M+5]={0};
    for(i=1;i<=n;i++)
    {
      for(j=1;j<=m;j++)
      {
        square=getchar();
        if(square=='*')
        {
          field[i][j]=MINE;
          for(k=-1;k<=1;k++)
            for(l=-1;l<=1;l++)
              field[i+k][j+l]++;
        }
       }
      getchar();
    }
    printf("Field #%d:\n",++field_num);
    for(i=1;i<=n;i++)
    {
      for(j=1;j<=m;j++)
        if(field[i][j]<0) printf("*");
        else printf("%d",field[i][j]);
      printf("\n");
    }
  }
  return 0;
}

 

posted @ 2013-02-23 05:41  三人木君  阅读(342)  评论(0编辑  收藏  举报